Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

WSS v3: Could not access the Search service configuration database

  Asked By: Dejuan    Date: Dec 27    Category: Sharepoint    Views: 2625

Wondering if anyone has run into the following error message when attempting
to start the Search service on a fresh installation of WSS v3:

Could not access the Search service configuration database

The architecture is a single front end web box and a separate SQL 2000
Standard Server located all on the same network / domain / switch / subnet.

The passwords check out, the database logins are correct, able to create a
system DSN and connect using SQL Server type, but looking in Event Viewer I
see the following:

Unknown SQL Exception 10054 occured. Additional error information from SQL
Server is included below.

A transport-level error has occurred when sending the request to the server.
(provider: TCP Provider, error: 0 - An existing connection was forcibly
closed by the remote host.)

Recently upgraded SQL 2000 to SP4.

Any thoughts?



8 Answers Found

Answer #1    Answered By: Tricia Mullins     Answered On: Dec 27

Have you tried turning off shared memory in sql  (in network  libraries) ?

Answer #2    Answered By: Himanshu Gohil     Answered On: Dec 27

Nope, can't say that I have... however that doesn't seem to do anything.

Answer #3    Answered By: Ashton Schroeder     Answered On: Dec 27

The onlly hellp me I can find is http://support.microsoft.com/kb/919797

Try reapplying the o/s service  pack to each box

Answer #4    Answered By: Iris Ballard     Answered On: Dec 27

On a side note this box  is also running WSS v2 side by side (not an

as for the tech document, don't think that's the fix.

Answer #5    Answered By: Jamila Guthrie     Answered On: Dec 27

It also says this can be caused by slow network  connections

Have you tried setting the port speeds on the servers and switch  ?

Answer #6    Answered By: Kalpana Ghatge     Answered On: Dec 27

It's a full duplex gigabit switch  with both boxes connected to the same
switch at full duplex. The wss  v2 instance uses the same SQL server
(different service  account) and has no problem.

Answer #7    Answered By: Bobbie Rodgers     Answered On: Dec 27

So anyone else have any ideas as to a flip that needs to be switched in the
SQL server  to properly allow WSS to communicate with it.

I've checked to make sure that I'm not fat fingering the password for the
user accounts...

Answer #8    Answered By: Bhumi Gokhale     Answered On: Dec 27

Verify named pipes and TCP/IP are enabled on the SQL instance. The WSS
Search account should be granted the proper access  automatically when
starting the Service.

The Farm Admin account must have SQL security administrator to properly
provision the WSS Search database. It must also have DB Creator rights.