Logo 
Search:

MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

WSS v2 - Reset Search Index

  Asked By: Ciera    Date: Aug 29    Category: MOSS    Views: 1010

on friday we had a complete hardware failure on our SQL server that held the
WSS v2 databases. Our server team built a new server, and was able to
restore backups to this server. I was able to get the sharepoint sites back
online, but I'm having an issue with the search function. I've been
searching for the proper way to reset the search index, so users can start
using the search function. All of my searches so far have resulted in
references to WSS v3.

Share: 

 

9 Answers Found

 
Answer #1    Answered By: Siobhan Waller     Answered On: Aug 29

Go into Central Admin and shut search off. It'll flush everything it
knows about search out. Then go back into Central Admin and turn search
back on. That should reset everything.



I had to do that a few years ago to recover from a SQL server failure.
WSS v2 uses SQL full text search, and SQL keeps that all in the file
system (at least SQL 2000 did) and we didn't restore that. I was able to
clear out the search configuration by shutting it off in Central Admin.
I had some troubles turning it back on though. Unless it's been fixed in
a patch, the "turn search on" web page waits until SQL gets everything
configured for search before it finishes. My environment had a lot of
content, and that page timed out. A lot. I extended every web page and
ASP.net timeout I could find to get it to successfully complete. I
finally ended up getting it to work, but I want to warn you that that
might be a problem.

 
Answer #2    Answered By: Lorenzo Steele     Answered On: Aug 29

I was finally able to get the search
re-indexed and working. Disabling and re-enabling did the trick, it timed
out a couple of times, but after a couple of hours all of the content was
indexed. This environment was on our road map to upgrade, but died before we
had a chance to get to it. funny thing is this was on a cluster until about
a month ago.

 
Answer #3    Answered By: Divakar Naik     Answered On: Aug 29

I have been searching for a way to reset the search index on a WSS v2 site
that I'm maintaining. The site search stopped returning results after our
content DB log file reached it's limit. Since the site search worked prior
to the log reaching it's limit, i'm hoping that resetting the index will set
things straight.

 
Answer #4    Answered By: Marcus Davis     Answered On: Aug 29

Go into Central Admin and shut off full text search. Then turn it back
on. WSS v2 uses SQL full text search, so there aren't indexes to clear,
like you're used to in other versions of SharePoint.

 
Answer #5    Answered By: Perla Vang     Answered On: Aug 29

I tried disabling and re-enabling the search from Central Administration
with no luck. After talking to the DBA, it seems that indexing was disabled
on the database. I have a request in to have this re-enabled, and I'm also
in the process of creating a MOSS environment to upgrade from WSS v2 to
MOSS. We have exceeded the limits of WSS by a long shot, one site collection
has a list with 177,000 items. And users wondered why it was so slow. This
was one of those environments that was supposed to be for a proof of concept
only, but turned into a production environment. Since there was no
SharePoint resource for a long time, it remained untouched from an Admin
perspective. My plan is to upgrade the database from SQL 2000 to SQL 2005,
then perform a DB Attach upgrade. I'm guessing the whole process is going to
take most of my weekend, since the database is about 150 gb. The plan is to
use this new MOSS environment as a staging are to clear out all of the
unused sites and content. Also we are going to through a process to ensure
the SharePoint environment meets our business needs, and is Architected
properly.

 
Answer #6    Answered By: Sandra Alexander     Answered On: Aug 29

NEVER LET A DBA HANDLE A SHAREPOINT DATABASE.

They like to play with tables that shouldn't be touched.

 
Answer #7    Answered By: Nalin Rao     Answered On: Aug 29

I agree, but unfortunately my hands are tied in this case

 
Answer #8    Answered By: Thomas Davis     Answered On: Aug 29

You might want to revise your expectations from "most of my weekend" to "most of
my week" if not "most of my month", depending on how much DB horsepower you have
available. A 150GB content DB with lists well above the recommended 2000 item
threshold is going to be as slow to upgrade as it is to run under WSSv2.

 
Answer #9    Answered By: Dominic Davis     Answered On: Aug 29

I agree, the process is going to be painful. I ran the upgrade from SQL 2000
to SQL 2005 over the weekend, and based on our hardward it took about 45
minutes. Then I moved onto the DB attach, which is where the fun started.
Turns out that my SQL backup didn't contain the running of prescan.exe. My
fault for not checking ahead of time. So the process begins all over again.
I'm wondering if there is a timeout while running the DB attach? I have a
server dedicated to this piece of the project, so I'm hoping that this won't
be an issue. I will probably try again tomorrow after the backups have been
run again.

 
Didn't find what you were looking for? Find more on WSS v2 - Reset Search Index Or get search suggestion and latest updates.




Tagged: