Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

All WSS site documents are always read-only

  Asked By: Franklin    Date: Apr 04    Category: Sharepoint    Views: 2062

I am writing to you in search for an answer to a question which I cannot answer
although I have struggled for some time.
We have Sharepoint Windows Services running internally and are having some
technical issues with the document control, and online editing.
Our server is a Windows 2003 with SharePoint Windows Services and clients
computers use Windows 2000/XP with Office 2003.

We experience the following problem:
Clients can log in with their user name and password and can access the Document
library within our Team Site.
In the document library they have all the rights (contributor, author). They
check out a document and then using the little menu, they want to open the
document for editing (option: Edit with Microsoft Word/Excel).
They can change the File Properties (Edit properties) – even the file name.

Up until now everything work perfectly! Now things get a little bit strange:
- while opening the document, the user is asked once again for his credentials
(another pop-up window for the user-name and password appear)
- and then the document opens in Read-Only mode (changes cannot be saved)
- I should probably mention that we can not use Word’s Option (Add a document to
the work space) it brings up an error – chances cannot be saved (document add)
- The users can see theirs documents with the web folders but documents are
still read-only
It looks like the user is not so “powerful” in the office environment.

I have found this subject in several posts but neither proposed a solution. The
posts are all a little bit old so I was thinking that maybe the solution is
somewhere out there and that I was not able to put my finger on it.
I found some two articles related on the Microsoft KB, but the solution
suggested did not do anything to our environment.

support.microsoft.com/default.aspx
support.microsoft.com/default.aspx

Any help will be greatly appreciated because we have been struggling with this
problem. We plan to use the WSS in the first time and then go to the portal
version. But if we can not get this working we will have a very hard time
convincing our management to go further on.

Share: 

 

7 Answers Found

 
Answer #1    Answered By: Dana Hodges     Answered On: Apr 04

I am not sure since I have been using only office
2003. But heard that EDIT is not supported in office
xp or 2k. Can some one update on this please.

 
Answer #2    Answered By: Kent Harmon     Answered On: Apr 04

Than you very much for your reply. I am aware that that function works best in
Office 2003 and we are currently using Office 2003 and the problem still
exists.
Even after doing everything that MS suggested in KB884050 and KB870853.
I forgot to mention that the anonymous access is not enabled and users access
the site  through a secure https connection.

 
Answer #3    Answered By: Alexis Pearson     Answered On: Apr 04

Do you have IIS bound to a specific IP address?

Do you have multiple Auth protocols enabled on IIS?

 
Answer #4    Answered By: Hugo Park     Answered On: Apr 04

Have you tried including the site  in question  to the IE Local Intranet Zone and enable login automatically to Intranet zone?

I would also check the IIS security settings to make sure they allow integrated authentication if the above scenario is followed and the user is on a trusted domain. also allowing basic authentication is the user is coming from an untrusted domain.

Given that you said the users have to login to the site itself, I have a hunch it has to do with their IE settings -- if IIS is set with integrated authentication and you are on your local network, you shouldn't have to login to the site, it should be automatic..

 
Answer #5    Answered By: Sterling Allison     Answered On: Apr 04

Than you very much for your kind reply and all of your time.
At IIS level we use only the Basic authentication. We have some users on the
local domain account and other users which have local machine accounts.
All users need to type in a password (prefixed by the domain name for those in
the local domain account).
Any way the problems appear in both situations. In fact if it were a problem of
authentication shouldn’t all access to the site  be forbidden?

I will try to explore a little bit more in that direction.

 
Answer #6    Answered By: Jessie Burton     Answered On: Apr 04

In IE:
1. Choose Internet Options from the Tools menu
2. Click on the Security tag
3. Choose the right zone (probably Local Intranet)
4. Click the Custom Level... Button
5. Scroll all the way to the bottom
6. Choose "Automatic logon with current username and password"

 
Answer #7    Answered By: Kristopher Morales     Answered On: Apr 04

To add to the list, they should also change their General->Temporary
Internet Files-> Settings to 'Every visit...' Usually this is set to
'Automatically which checks the local hard drive first and if it doesn't
find the page then it goes to the server.

 
Didn't find what you were looking for? Find more on All WSS site documents are always read-only Or get search suggestion and latest updates.




Tagged: