Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

New wss site Blank page on Fresh Win2008 x64 - SQL2008 - WSS3 setu

  Asked By: Sandy    Date: May 14    Category: Sharepoint    Views: 1188

I hope the bellow text is not too confusing - that it is understandable. I spent a lot of time to figure out what my problem was the following weird problem. Just tought I could share theinformation with the mass. So, the problem I got was while playing with a completely fresh install of WSS 3, on a brand new installation of SQL 2008, on a brand new install of Server 2008 x64. When the install was done (followed some good article on Google showing how to install fresh on the above software suite), I created my first Web Application, and then my first Site Collection, gave my user admin rights on that collection - regular stuff so far. All went well, with no errors. Since this is a test machine, I added a hosts entry to have the newly created site point to the local machine, using the real IP address, not the loop back IP. All happy that it worked with no serious glitch (so far), I tried opening my site....but got prompted for login. No matter what I entered, I would always get the popup asking for credentials. I first tought to add the site to my Local Intranet Zone in IE, wich is a good idea anyway, but it still would not work - always got prompted for credentials. Now, the weird part was that if I pressed cancell a couple times, I finally got a blank page - no login failed, or 401, or any other message, but just a bare blank page. I then remembered that we had a similar problem at work after an update where we could no longer get into MOSS SSP site. The origin of the problem is a certain KB (Sorry cannot remember which one) for .NET 2.0 I believe, which caused local pointing hosts entry to deny access or something similar. This happened at IIS level, so this is why I was not getting a SharePoint error, but just a blank page. The solution is easy enough once you know it. It is to add the local hosts entries to the registry in a specific key. To fix the problem, open RegEdit on the server to : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0 If it does not exists yet, create a multi-string value called : BackConnectionHostNames In there, enter the HOST name of your sites, each one on separate lines. So if your site you try to access locally is called "http://intranet/sites/test", you will enter "Intranet" on a separate line - just the host portion of the URL. Close regedit, do an "iisreset /noforce" and it should now work. I believe this happens on any platform that intalled the KB. I hope this was usefull for somebody, and will spare long google wacking to somebody



No Answers Found. Be the First, To Post Answer.