MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Workflow and group problems

  Asked By: Nakul    Date: Jun 05    Category: MOSS    Views: 663

Two questions: On my machine when I open a Word document from my email
generated task, the "Workflow Task: Please approve...... Edit this
task..." doesn't show up above the document. On other machines it does
for me and when someone else logs onto this machine it does. I've seen
this for other users as well. Any ideas?

Secondly.... Does anyone know if it is possible to limit the edit
rights even more specifically in a group? We want workflow approvers
to not have the edit document ability and in the default selection the
approve rights is tied with the overall edit rights. I know that they
have to have the edit list ability since by definition they are
changing the list in the approval process. Our rather ugly work around
is moving people between groups when they need to be in the approval
workflow, and then when it is finished moving them back.



5 Answers Found

Answer #1    Answered By: Latanya Nieves     Answered On: Jun 05

Regarding your first question: what version of Word do you have on your
machine? If you don't have 2007, that would probably be the reason for the
reduced functionality.

Answer #2    Answered By: Myron Calhoun     Answered On: Jun 05

but we're a 2007 office shop, and I
mentioned that others logging onto the same machine  have the
functionality, so it's definately a profile issue. I was hoping
someone had a fix besides deleting the profile since i'll have to
apply the fix to other users  as need be.

Answer #3    Answered By: Rena William     Answered On: Jun 05

If the workflow  panel doesn't show  in word  2007 you can toggle it open  from the
server menu on the Office button menu. It's a toggle that remembers whether you
had the panel open the last time you were in Word. Its an individual setting
stored in your office personalization profile. That's why others see the panel
and you don't.

Answer #4    Answered By: Shanda Nolan     Answered On: Jun 05

#1 - Assuming that you are using word  2007 you can open  the panel for the
Workflow task  by clicking on Prepare >Properties in the Office Button menu.
This is where the document  Information Panel is and it tends to remember the
last state that the individual user had it in. You may have closed it during a
previous word session. After opening the panel you may have to switch which
panel is being displayed by using the dropdown in the upper left corner of the

#2 - I think the only way to do this is to add code into your workflow  that sets
the document permissions to ReadOnly after starting the workflow. Permissions
on the task list  are left normal. Then have the Workflow re-inherit permissions
for the document when the workflow is complete. If you are using SPD for the
workflow you will need a custom action to do this. The following code project
may help. www.codeproject.com/.../CustomActivity.aspx

Answer #5    Answered By: Bailey Lewis     Answered On: Jun 05

For the second question, you want to customize certain list
permissions to certain people. The following SharePoint permission
features may be helpful to you.

Didn't find what you were looking for? Find more on Workflow and group problems Or get search suggestion and latest updates.