Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds


  Asked By: Tessa    Date: Jun 29    Category: Sharepoint    Views: 998

I created simple workflow where if a item is added to a list, a new item
is created into some other list.

It works very well but only for me. It does not work for anyone else.

I checked the permissions on both the lists. I gave user contribute
permission on both the list. Though I dint want to give any permission
on the other list but still for testing purpose I did. When I do it from
their, it again works.

Can anyone please what am I missing...?



5 Answers Found

Answer #1    Answered By: Jocelyn Shelton     Answered On: Jun 29

Workflows run under the context of the current user, and since they make
changes to the metadata of the original list  item, the user  will require
contribute permissions. As for the other list, because of the user
context being used in the workflow, the user will require contribute
permissions on that list as well since they are the ones creating the
new item  there.

Answer #2    Answered By: Joey Soto     Answered On: Jun 29

Thinking the same I gave them contribute permission on both the list  but
still it works  only for me.

Answer #3    Answered By: Gerard Randall     Answered On: Jun 29

If you are using SharePoint Designer for the workflow  I have found the
following two solutions that have worked for me:

WORKFLOW = users not accessing TASKS even after assigned correct

Site must inherit permissions  from parent site.

If add people after create workflow.

In SharePoint Designer > right click on workflow > Properties > Security
Tab > Manage permissions using Browser . OPEN and SAVE.


Open SharePoint Designer

Right Click on Workflow

Select Publish Selected Files

Choose FILE SYSTEM and write a location (C:\ for example)

Click on OK

Answer #4    Answered By: Audra Mccormick     Answered On: Jun 29

I did as mentioned by you but it still dint work.

Any other suggestion...??

Answer #5    Answered By: Christina Lewis     Answered On: Jun 29

Actually the workflow  get started but it doesn't complete, it says the
following from the history:-

User ID:- System Account

Error updating a list item  Access denied

Why is it running under system account when I have configured my app
pool to run under a different WSS admin account...??

Didn't find what you were looking for? Find more on Workflow Or get search suggestion and latest updates.