Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Windows SharePoint Services Configuration Database

  Asked By: Gonzalo    Date: Dec 12    Category: Sharepoint    Views: 1868

I'm facing problems installing Windows SharePoint Service's configuration database on a SQL Server with non-standard-named instance.
My company's production SQL Server doensn't use the standard "default instance". It's named according to the enterprise rules and I can't change that.
I'm running the WSS setup with the remotesql option. (setupsts.exe remotesql=yes)
After the installation of WSS, on the HTML Administration pages, I'm asked to create the configuration database. If I fill the Database Server field with Server\InstanceName I get "SQL Server 2000 Service Pack 3 or later is required". I've tried to use the command-line utility but I still get the same error.
stsadm.exe -o setconfigdb -ds Server\InstanceName -dn sts_config -hh
The SQL Server is online, the instance is running perfectly. I'm using SQL Server 2000 Service Pack 4.
I've done this before several times using the default instace and the configuration goes ok.
Do you know if it's possible to store windows sharepoint services configuration database on sql server with a named instance?



14 Answers Found

Answer #1    Answered By: Irvin Foley     Answered On: Dec 12

Yes, it’s possible to install WSS on a named  instance. Have you checked the application pool identity and made sure that it has access to the DB?

Answer #2    Answered By: Deonte Stein     Answered On: Dec 12

The application pool identity is assigned the "Database Creators" and "Security Administrators" roles. I think the setup  just won't understand the meaning of the backslash separating the computer name from the instance  name. It seems it doesn't even try to get a connection. If I put only the computer name, it delays a little and I get a connection failed message (correctly). But when I put the instance name it doesn't try to connect. It just gives me the "SQL server  2000 Service Pack 3 or later is required" message instantly. Is there another way to set the configuration  database not the web interface nor the stsadm command line tool?

Answer #3    Answered By: Stephon Valentine     Answered On: Dec 12

yes indeed, i have sql  installed on a named instance  as well..just saw that you
had sp4, i havent gone there yet, could that be the issue?

Answer #4    Answered By: Leif Cardenas     Answered On: Dec 12

I don't remember clearly if I've already tested this using sp3, but I'll try it today anyway.

Answer #5    Answered By: Jasper Hatfield     Answered On: Dec 12

interesting.. ive got a heck of a sandbox so i will try connecting to a named instance  with sp4 as well. thats an interesting problem.. i am sp3a and connect to "tigger\devsps" instance no problem.

is this seperate machines? you arent using any SBS, just plain old windows  2003 server  with SPPS connecting to another windows 2003 server with SQL2k?

also, have you tried to connect to the named  instance from the portal front-end box using osql or similar?

ill let you know what i find with the sp4 thing as well.

Answer #6    Answered By: Rashawn Hopper     Answered On: Dec 12

I've tested it with sp3 this morning. The problem persists. It's really weird. I'm not using any SBS. The point is I'm not installing  SPPS. I'm instaling WSS as a pre-requisit for project server. I've read about the SPPS setup  and it really works with a named  instance. WSS is embeded in SPPS setup. But with project server  you're required to download and install WSS first, and that's where I get my error.

Answer #7    Answered By: Horace Coffey     Answered On: Dec 12

Just out of curiosity, what is the name of the named  instance? Are there any non-alphanumerica characters embedded in either the server  or instance  name?

Answer #8    Answered By: Rigoberto Beard     Answered On: Dec 12

The instance  name is Instance1. There are no non-alphanumerical characters... The only non-alphanumerical character is the backslash that separates de computer name from the instance name. Do you think that might be the problem?

Answer #9    Answered By: Alphonso Mckay     Answered On: Dec 12

when you do it on the command line, try enclosing it in quotes.

Answer #10    Answered By: Daron Oneill     Answered On: Dec 12

I'm starting to think that the sp3 is the problem. Someone told me the sql  sp3 setup  takes a long time to run and mine runs in the blink of an eye...
Maybe the file is corrupted so the sp3 is not applyed correctly.
I'll download it again and retry.

Answer #11    Answered By: M Juarez     Answered On: Dec 12

i just had 0 problems  doing it on a named  sp3, and sp4 instance. its got to be either IIS app pool ID or something wacky with sql  server... i wish i had an answer now for you, but really cant get the problem to occur in my environment

Answer #12    Answered By: Marty Mcdowell     Answered On: Dec 12

Try adding it as a system administrator long enough to create  the database… I think there’s something else it is looking for (I can’t remember what.) I know it’s OK with the instance  name. I do it all the time for clients.

Answer #13    Answered By: Dakota Shaffer     Answered On: Dec 12

Finally! It's working! The problem was the sql  sp3. It was corrupted, so it was not installing  correctly. I downloaded it again and reinstalled.

Answer #14    Answered By: Ted Gilmore     Answered On: Dec 12

sometimes the most obvious of symptoms are overlooked.. i wonder if you ever saw any other strange behavior like not being able to log into it from EM on another box.

Didn't find what you were looking for? Find more on Windows SharePoint Services Configuration Database Or get search suggestion and latest updates.