Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Windows 7 users are unable to access Explorer View within SharePoint

  Asked By: Keon    Date: Jul 07    Category: Sharepoint    Views: 25091

I've been scouring the net for weeks now trying to resolve this issue...

The majority of our users have windows XP as their OS and have no problem saving
files directly to SharePoint by selecting the relevant document library from "My
Network Places". A few users have now upgraded to Windows 7 (with IE8) and can
no longer do this.

The XP users added document libraries to their "My Network Places" by visiting
the SharePoint site and changing the view to "Explorer View". This automatically
created the corresponding web folder in "My Network Places".

1) My Network Places is not available in Windows 7.

2) Explorer View does not load (The following message is displayed: "Internet
Explorer cannot display the webpage")

3) When selecting "Open with Windows Explorer" nothing happens.

Therefore it is not possible to save files directly to SharePoint meaning every
file needs to be saved to the users hard drive and then uploaded using the
upload facility.

Setup:
- SharePoint 2007 SP2
- Windows Server 2008 r2

IE8 is fully updated. The WebClient service is running on the server and client
machines. I have also tried the "patch" from Microsoft which resets webfldrs.msi
(which isnt included in windows 7) : Software Update for Web Folders (KB907306)
www.microsoft.com/.../details.aspx\
-987622ed1d64&displaylang=en

If anyone has any ideas at all I'll try anything!

Share: 

 

13 Answers Found

 
Answer #1    Answered By: Jared Bell     Answered On: Jul 07

Are the Windows7 users  on x64? If so, are they using the 64 bit version of
Office? Anyone using a 64 bit version of Office on a 64 bit OS will have
issues with the Windows explorer  view of SharePoint because it is dependent
on an ActiveX control loaded by Office. The particular control is only
loaded when you install a 32bit version of Office. That's the most common
issue I see where explorer view  doesn't work in Windows 7.

 
Answer #2    Answered By: Elsa Chan     Answered On: Jul 07

I assume that MS will be issuing some sort of fix for this one?

 
Answer #3    Answered By: Daya Sharma     Answered On: Jul 07

I doubt it. Microsoft recommends installing 32bit Office by default, except for
a handful of reasons.

Here is the technet article:
technet.microsoft.com/en-us/library/cc261754%28office.12%29.aspx

 
Answer #4    Answered By: Viren Rajput     Answered On: Jul 07

This link goes to a TechNet article regarding file types and iFilters...
where is the reference to 32bit Office?

 
Answer #5    Answered By: Jonathan Thompson     Answered On: Jul 07
 
Answer #6    Answered By: Joanna Dixon     Answered On: Jul 07

We're using SharePoint 2007.........................

 
Answer #7    Answered By: Bret Warner     Answered On: Jul 07

I don't know if they will or not. So far the comments have just been that
people should use the 32 bit version of Office even on a 64 bit OS.

 
Answer #8    Answered By: Jesus Davis     Answered On: Jul 07

I was going to try this but it turns out we're not running 64-bit
Office.

Does selecting  Explorer View carry out the same action as open  with Windows
Explorer? I find it strange how neither work.

As a workaround I tried mapping the drives (which seemed to work) but when I go
to open (use) this newly created network  location nothing happens. I've since
restored a full backup of SharePoint and SQL to an old server we had and I was
able to map and use the locations as expected. Using this server is not a viable
option but it does suggest that something is configured differently on our
current server...

 
Answer #9    Answered By: Christin Fitzgerald     Answered On: Jul 07

Could this be related?

" You cannot connect to a document  library in Windows SharePoint Services
3.0 or Windows SharePoint Services 2.0 by using Windows shell commands or by
using Explorer View"

<http://support.microsoft.com/kb/841215>

This is a problem  related to Basic Authentication. The client defaults are
different under Vista and Win 7 than under XP.

 
Answer #10    Answered By: Clayton Berry     Answered On: Jul 07

We have this same problem  after switching our users  to Vista. Explorer View
doesn't work, multiple upload to picture libraries  doesn't work, some users
can't save  a document  back to sharepoint  after they have opened the document up
from sharepoint (they only have the option to save it to their computer).

Our current work around is to create custom network  locations to the top of the
site collection that the user still has access  rights to.

 
Answer #11    Answered By: Tosha Pace     Answered On: Jul 07

I tried all the regedits but unfortunately none of them had any
effect.

 
Answer #12    Answered By: Marcie Rivers     Answered On: Jul 07

Try the following, it is an authentication problem



1. Click Start, type regedit in the Start Search box, and then press ENTER.

2. Locate and then click the following registry subkey:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters

3. On the Edit menu, point to New, and then click Multi-String Value.

4. Type AuthForwardServerList, and then press ENTER.

5. On the Edit menu, click Modify.

6. In the Value data box, type the URL of the server that hosts the Web
share, and then click OK.

Note You can also type a list of URLs in the Value data box. For more
information, see the

"Sample URL list" section in this article.

https://site.com or https://*.site.com

7. Exit Registry Editor.

8. restart webclient service

 
Answer #13    Answered By: Edmond Kidd     Answered On: Jul 07

This was already in place in the registry. I did however
recreate it but it didn't resolve  the issue.

 




Tagged: