Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Who's installed the SharePoint Training Kit?

  Asked By: Hiral    Date: Aug 11    Category: Sharepoint    Views: 1578

Installed the training kit into sharepoint to access the training
materials.

At first I downloaded and installed the SharePoint Learning Kit from
Codeplex. Apparently, that was the wrong thing, as that contains no
actual training materials.

So then I went to grab the Sharepoint TRAINING Kit from Microsoft's
connect site:

https://connect.microsoft.com/site/sitehome.aspx?SiteID=479

Note that the above link likely won't work unless you've registered at the site.

I ended up installing the SharePointTraining.msi file on our farm, and
went through the installation doc to implement the solution, activate
it in central admin, and modify DB user settings in SQL.

I then went to my web application top site collection, made a training
site using the template, and everything seems to work, EXCEPT that no
actual training modules appear under any of the training sections
(collaboration, ECM, Business Process and Forms, etc...)

Did I omit a step? Is that a sign of any obvious mistake I might have
made installing this thing?

Share: 

 

16 Answers Found

 
Answer #1    Answered By: Tyrone Meyer     Answered On: Aug 11

you might have missed something Trainning kit  is now available on Microsoft
Downloads and use that to install the one it works like Champ. It is great
material you can get for free.

Here is the Download URL for the same

www.microsoft.com/.../details.aspx\
-16d685600a51&DisplayLang=en

 
Answer #2    Answered By: Dean Neal     Answered On: Aug 11

Sorry for the confusion. That is, indeed, what I installed  (that's
what the connect site  links to).

I didn't get any errors and everything seems to work  just fine, just
that might actual training  modules are empty.

Looks like I'll try an uninstall and complete reinstall in the AM.

 
Answer #3    Answered By: Vincent Griffin     Answered On: Aug 11

Did you install it on a farm? I had a post about this today but nobody
responded yet. On a standalone MOSS installation, the training  kit
works great, but it looks like the installation  instruction does not
work on a farm.

I have the same problem as DA mentioned.

 
Answer #4    Answered By: Antoine Barker     Answered On: Aug 11

For what it's worth, I installed  it in a farm  (2 WFEs and a separate DB
server) and it worked fine for me. I think I had a similar problem
though when I initially installed it on our test server and then
decided to install it on a different web  app. It's been a few months
so I don't recall how I ended up fixing it but I think I just
completely uninstalled and then re-installed.

 
Answer #5    Answered By: George Watson     Answered On: Aug 11

Yes, it was a farm  install.

I had installed  it on a standalone server, too, but didn't know how to
access the DB to add the DB permissions on that one (does standalone
run SQL Express?)

Did you have the same symptom on your farm? (everything installs
and runs except the actual training  materials themselves)

 
Answer #6    Answered By: Gabriel Patterson     Answered On: Aug 11

My standalone MOSS uses SQL Server 2005 on the same box and the traing
kit works great. I don't have much knowledge about SQLExpress.

On the farm  (2 wfe, 1 app/index, and 1 db), as you noticed, the
installation went well, but no content uploaded. I did a complete
reinstallation (uninstall first) and the same result.

I also found out that you could manually upload the content, but it is
a pain. Also I believe the content is NOT uploaded into the database, FYI.

I contacted MSFT about this and am waiting for a callback. I will let
you know what I get from MSFT.

 
Answer #7    Answered By: Victor Hughes     Answered On: Aug 11

Do let us know if you hear from MS. I did send an
email via the link  they had on the Connect site  for feedback, but I'm
not holding my breath on getting a reply.

I'll poke around our standalone install server. I THINK it was SQL
Express...I'll have to figure out how to access  the permissions on
that.

 
Answer #8    Answered By: Gordon Blair     Answered On: Aug 11

Make sure you deploy the solution  to your destination web  application.

 
Answer #9    Answered By: Barry Burke     Answered On: Aug 11

Pretty sure that I did that step  according to the instructions.

 
Answer #10    Answered By: Erick Carlson     Answered On: Aug 11

Finally MSFT sharepoint  support called me back last Friday. After on
the phone for half an hour, including explaining what MSFT SharePoint
Training kit  is, the support guys asked me to copy the license
agreement to Word so that he can point out that MSFT does NOT support
the training  kit. So as a MSFT policy, he said he could not help me in
any way, shape or form.

I am the biggest advocate of SharePoint in my firm and I am speechless.

 
Answer #11    Answered By: Rashad Huff     Answered On: Aug 11

When I first tried to install this, I got excellent support from:
sptbeta@...<mailto:sptbeta@...>

Don't know if it still works, but might be worth a shot.

 
Answer #12    Answered By: Henry Henry     Answered On: Aug 11

Me too. sptbeta@... helped me a lot.

I'm very please with their supports for this beta product.

I got my SharePoint Training Kit up and running in no time.

 
Answer #13    Answered By: Francisco Simpson     Answered On: Aug 11

I'm not surprised they don't support this. We can barely get support
for MOSS ingeneral from them. Nor am I surprised a year after it's
release, one still can't find basic training  for MOSS from Microsoft.
Frustrated and bummed, but not surprised.

I finally did get a response from the email support link  on the
training site. Alas, the response was fairly vague. In summary they
said that the fact that the modules didn't appear means "I did
something wrong  during installation...do it again"

So, I went through the entire process  of deactivating, deleting and
uninstalling, and this time installed  it step-by-step-by-step-by-step
and still...same thing. I sent a reply back and we'll see if we can
narrow the issue down.

For those of you that have it installed, can you confirm it's on a
multi-FE farm?

 
Answer #14    Answered By: Saul Cobb     Answered On: Aug 11

Our install is only on a single FE farm. I must admit, I got a similar response
the first time I had issues installing  the kit  - but they were bang on the
money. I was trying to install the kit into a site, rather than a site
collection as the manual said. (The site  collection bit wasn't emphasised, so I
figured I had some liberty in wether I used a collection, or a sub-site.
Wrong!).

 
Answer #15    Answered By: Karl Reid     Answered On: Aug 11

My installation  is also on a single FE farm. I also installed  the
client training  kit for users who want to study MOSS off-line -- on
their laptops without connecting to MOSS servers. I like the client
version better than the server version myself.

 
Answer #16    Answered By: Lionel Phelps     Answered On: Aug 11

A long overdue update on the SharePoint training  Kit Install issues...

https://connect.microsoft.com/site/sitehome.aspx?SiteID=479

After a few back-and-forths from the support email, I discovered that
when you run the .MSI installer on the server, it also puts all of the
individual training modules (ZIP files) on the server as well.

The problem I, and apparently a LOT of people are having is that the
site installs, but the training kits don't. The workaround is to
manually upload the ZIP modules individually to the training library
after the site  is installed.

The catch is that the ZIP files aren't organized and you need to
re-enter the meta information as you upload.

The easiest way to figure that out is to use the WSSDemo site as a guide:

http://www.wssdemo.com/training/default.aspx

After a lot of frustration, we finally have some working training
materials for our users!

Now...the follow-up question! How does one 'approve' training
sessions? In testing the modules, we would view one and then hit
'Complete Training' which apparently sends it to 'my instructor' for
approval. Until then, the module disappears for me.

I have no idea what this is. I assume it's some sort of workflow? How
does one view the training site as an instructor to actually do this
approval step? Anyone know?

 
Didn't find what you were looking for? Find more on Who's installed the SharePoint Training Kit? Or get search suggestion and latest updates.




Tagged: