Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

WebService Question

  Asked By: Sanchay    Date: Aug 27    Category: Sharepoint    Views: 880

I wrote a webservice to programmatically create sites and am having
trouble. I have WSS installed on a laptop running Windows server
2003. When I run my webservice locally to create a site on this WSS
installation it works.

I can create a site under http://<server1>/sites/siteA/

I also have a Windows 2003 server that has a separate WSS install on
it. I pushed my webservice to that server and tried to run it (by
adding a reference to it in VS.NET 2005 on my local). I am getting
this error:

The Web Application at http://<server2>/sites/siteA/ could not be
found. Verify that you have typed the URL correctly. If the URL
should be serving existing content, the system administrator may need
to add a new request URL mapping to the intended application.


Site A on this server does exist. I don't know my web service can't
find it.

I have tried:
impersonating the admin user in my webservice
calling a SOAP webservice (I've read this was required for 2003)
changing <server2> to the IP and port number

Is there anything I am overlooking?

Share: 

 

4 Answers Found

 
Answer #1    Answered By: Chantal Rosa     Answered On: Aug 27

Where is your web service located at when you try to hit it on
server2? If the webservice  you are trying to hit is not on the actual
server that is serving WSS you might run  into Code Access Security
issues between the servers. Also, you might want to make sure the
webservice is defined in an exluded path by going to central admin,
WSS, define manage paths, and excluding the path to the Web Service.
Impersonation can be good but for the web service to be able to access
certain ojbect model elements you will need to ensure that the web
service has the aforementioned CAS to it. If you bump up your
web.config to give full trust. If this fixes your issue then your
having a CAS problem.

 
Answer #2    Answered By: Kyla Eckert     Answered On: Aug 27

The web service is on the WSS server. I have turned off anonymous
access and set identity impersonate=true. Do I need to impersonate a
user that has full WSS rights (or the user running  the app pool)?
When you say "make sure the webservice  is defined in an exluded
path," where is the option to exclude? I only see wildcard
inclusion and explicit inclusion. I tried change it to full trust
with no luck. I am getting an error: "The web application at
http://<ip address>/sites/siteA/ could not be found. Verify that you
have typed the URL correctly. If the URL should be serving existing
content, the system administrator may need to add a new request
mapping to the intended application.

Any idea what that error is? Google didn't find much.

 
Answer #3    Answered By: Alisha Holmes     Answered On: Aug 27

all non-included paths are excluded in 2007/V3, there is not need to define an excluded path.

also check your alternate urls in central admin to verify the URL is indeed defined as a valid namespace. the error below sometimes points to an IIS change without the correlating default internal URL change. also, all app pool identities must be local admins on every server in the farm.

 
Answer #4    Answered By: Damon Garner     Answered On: Aug 27

This does not mean that SharePoint and
non SharePoint pages can be mixed within any given folder. Only the root
and designated Managed Paths (SharePoint Virtual Directories represented
by meta data in the database) can contain Site Collections. Only true
IIS Virtual Directories can contain non-SharePoint content. While I
haven't tried it, I suspect that one could use the root for
non-SharePoint content as long as no Site Collection had been created in
it.

 
Didn't find what you were looking for? Find more on WebService Question Or get search suggestion and latest updates.




Tagged: