Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Web part error after installing Active Directory - SP2003

  Asked By: Prince    Date: Apr 11    Category: Sharepoint    Views: 838

After installing Active Directory, I receive this error on all of the
web parts on all of my sites (SP Portal 2003):

<Web Part Error: One of the properties of the Web Part has an
incorrect format. Windows SharePoint Services cannot deserialize the
Web Part. Check the format of the properties and try again.>

I've read the following:

<This issue may occur when permissions that Windows SharePoint
Services configured on the Windows Temp directory were unintentionally
reset , possibly when you upgraded your operating system.>
from http://support.microsoft.com/kb/826786

But I'm unsure of where to go and what to change to fix this problem.
Any ideas?



4 Answers Found

Answer #1    Answered By: Christie Carlson     Answered On: Apr 11

You cannot change the names of servers participating in a SharePoint
2003 farm. By installing  Active Directory you effectively changed the
name of the server and all the SharePoint config and content databases
still have the name of the old server. I'm surprised that your sites  run
at all.

Answer #2    Answered By: Dorothy Farmer     Answered On: Apr 11

Good to know. Actually, the document libraries, etc., are just fine -
but the web  parts all give the error. I was going to install MOSS
separately on this server (gradual install). What are the chances of
being able to import my 2003 sites  to a fresh MOSS installation
either on this server or a separate server? I could easily recreate
the web part  pages in MOSS if the lists and libraries still exist. I
have a fresh backup (before AD) of the SP 2003 installation using
SharePoint Backup & Restore. Thanks for any advice you can give me.

Answer #3    Answered By: Jacklyn Burnett     Answered On: Apr 11

I installed an update to the server: Win SP Svc 2.0 Svc Pack 3 -
and it fixed my web  parts! - everything appears fine now.

Now... the goal is to install MOSS on this server today and do a
gradual upgrade with the databases from 2003. Some of the sites  will
remain on this server while others we will want to port to a separate
MOSS server.

I already have a backup using SP2003 Backup & Restore. However, I
would like to make sure that I have a separate backup of the SQL
databases. I asked this in another inquiry last night, but can
anybody point me to directions on backing up the SQL databases from a
MS SQL Server Desktop Engine (SharePoint) installation? This is the
only SQL Server that I can find installed on this server.

Once I'm confident of having a good backup, I'm going to install
MOSS. At that point, I'll be installing  SQL Server 2005. Do you see
any potential issues in installing SQL Server 2005 on a server that
has MS SQL Server Desktop Engine installed?

Answer #4    Answered By: Breann Beach     Answered On: Apr 11

Sounds like a plan..

Please keep informed of process and thank you for sharing your

Didn't find what you were looking for? Find more on Web part error after installing Active Directory - SP2003 Or get search suggestion and latest updates.