Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Warm up script...

  Asked By: Tommie    Date: Sep 02    Category: Sharepoint    Views: 982

for the warm up script to force the JIT for all of our SP pages. I got
the files, made the changes that Joel said to make, and when I ran the
script, after the initial title in the command prompt, it
said, "Command Line Error". Then it listed what all of the stsadm
commands are, and proceeded to "Hit" all of the SP pages that I had
specified, but when I go to those pages right after, it takes 20-30secs
to render the page.

Did I do something wrong? The only changes I made to the files was
adding the hostname to the Startup.bat file, and adding the URLs to the
Warmupserver.cmd file.



5 Answers Found

Answer #1    Answered By: Chadd Hahn     Answered On: Sep 02

The "Command Line Error" is generated because the script  calls STSADM without
any parameters, which is enough to warm  it up, but does generate the error. You
can safely ignore it.

Answer #2    Answered By: Cheryl Kelley     Answered On: Sep 02

If you want to get something a little more useful in place of the error
message, try adding  "-o enumzoneurls" to the stsadm command.

Answer #3    Answered By: Titus Sweet     Answered On: Sep 02

OK. That's good to know, but the problem remains that it's
not "Warming up" the sites. It still takes  20-30 seconds to load the
site the first time. Second time, it works in a snap

Answer #4    Answered By: Jagdish Joshi     Answered On: Sep 02

What user context are you using to access the site in the warmup, and
what sort of content is included on the page(s)?

Answer #5    Answered By: Shara Johnson     Answered On: Sep 02

I am running the script  as the SharePoint System Account. I'm just
trying to warm  up our main portal, central admin, and our extranet.

Didn't find what you were looking for? Find more on Warm up script... Or get search suggestion and latest updates.