Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

User Access to the document folder structure

  Asked By: Abhishek    Date: Mar 19    Category: Sharepoint    Views: 1603

I'm having a User Access issue to the document folder structure. I have
two users in a domain local group. I gave this group access to
SharePoint with the "Reader" role. This is confirmed because these do
not see the "Content" or "Layout" link in the top right corner. When
these users navigate to the document library, they are able to create
folder and document and able to delete also. My understanding of the
reader role is that they should not be able to do any of these tasks,
they can only view published documents. I did confirmed that these
users, when doing a search, do only get results for published documents
and not draft documents. What is wrong or how do I go about fixing this
issue?

Share: 

 

7 Answers Found

 
Answer #1    Answered By: Jerome Montgomery     Answered On: Mar 19

Check the permissions again. Authors won't get content  and layout
either. Permissions are cumulative. Users get the highest level
available for them. You probably gave another group  they had the
Author role. BTW, Search always returns published. The index
doesn't use checked versions. You only see published  versions
regardless of permissions.

 
Answer #2    Answered By: Serena Schwartz     Answered On: Mar 19

I verified the security at the workspace (MMC) and at the documents
folder (web folder). I assigned the group  as a reader  at the workspace
level therefore it propagated all the way down the structure. But I'm
still able to create and delete  folders and documents. I originally
assigned this group with an author role  and then I changed it to the
reader role. Do I have to reboot the server or restart the services to
have this take affect?

 
Answer #3    Answered By: Tiara Gross     Answered On: Mar 19

Just ran into this myself yesterday. A reboot will solve it. Also
recycling all the SPS services. IIS restart won't. What appears to
happen is that the server fires up a process for each workspace and
tracks acl's and caches there. It just stops accepting acl changes.
In my case, when I added a new user  to one workspace (others were
fine)we would get errors anyplace where "everyone" wasn't allowed (I
know, I know, I've said that best prctice is to remove that group,
but I'm a consultant). I wasted hours tracking it down. Rebooted in
a maitanence window and everything's fine. Is this a known bug? I
haven't upgraded to SP2 yet. Need a maintenance window.

 
Answer #4    Answered By: Frankie Figueroa     Answered On: Mar 19

Has anyone else run into this? Is this fixed by sp2? My server has
been up 3 weeks. Should I start a weekly reboot?

 
Answer #5    Answered By: Wesley Myers     Answered On: Mar 19

The reboot solved the problem. But here is another weird thing. I went
and change the role  of the group  from Reader to Coordinator and it
allowed me to do everything, i.e., delete  and create folders and
documents. Does the reboot only applies if you are changing the role
from either a Coordinator or an Author to a Reader? Because I didn't
have to reboot when I changed the role from a Reader to a Coordinator.
If somebody knows what is happening

 
Answer #6    Answered By: Shailendra Shinde     Answered On: Mar 19

I have had these issues on regular basis for several
Sharepoint installations. If I add a new user  or
group to Sharepoint then I need to recycle the services, actually
the service running WSS is the one that needs to be recycled, but
if I re-assign a known user to another role  then everything works
directly.

So it´s seems to be a problem when Sharepoint need to fetch the
new user information from a directory service (AD or NT 4.0 domains).

According to MS there can be some latency when assigning new
users and groups and recommend using groups when assigning
permissions.

This issue  haven´t been fixed in SP2.

 
Answer #7    Answered By: Yessenia Dejesus     Answered On: Mar 19

Which is true in our case. We've solved it by rebooting the server every
night. Probably not a perfect solution, but at least we can say "if anything
goes wrong, tomorrow it will work fine".
SP2 didn't resolve it.

 
Didn't find what you were looking for? Find more on User Access to the document folder structure Or get search suggestion and latest updates.




Tagged: