Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Usage Analysis Stopped Working

  Asked By: Amos    Date: Apr 27    Category: Sharepoint    Views: 3290

I thought the usage analysis graphs were pretty slick. They were working
on my farm after I enabled Usage Logging in Central Admin, and then
Analysis Processing in each SSP.

Now Usage Analysis has stopped working.

I can still see usage logs in 12/LOGS/Usage where I told C.A. to place
them, but when I run the graphs they are blank.

I was thinking back to when they stopped working and I do recall once
that my system locked up for an OWSTIMER memory leak, and I hosed things
even worse by deleting the search indexes (Which Process Locked up)
thinking search was the problem. It doesn't seem to be related, but that
is when things stopped working.

I also during this same period of time changed associations of the web
application to a different SSP. I wondered if the service accounts for
my SSP were not set up correctly.

Usage analysis graphs are not working for applications in either SSP.


"Enable Processing Between"

Is this when the timer job runs, is this when data is tracked, or is
this when users are allowed to run the graphs?



3 Answers Found

Answer #1    Answered By: Linda Mason     Answered On: Apr 27

I would uncheck the service  in Central Admin, delete the previously
specified content, re-check the box and see if that fixes it. That
should wire-up a new owstimer job.

The 'between' times can be a little confusing. If you specify 10am-10am,
for example, it will run  until complete. If you specify 10am-12pm, then
it will run for two hours and stop.

Answer #2    Answered By: Hans Weiss     Answered On: Apr 27

I've done that so many times over the past 3 weeks and it doesn't
seem to work. I run  the job-usage-analysis manually. Still No-go

Maybe it has to do with the processing  times I have set  up. I tried
setting it to a longer period  of time, but now I have to be patient
for a couple more days to see if it worked.

What is interesting to me is one shared service  provider has
historical information back  to mid-september when it stopped  working,
but I deleted all the log folders.

Do these logs  get imported into the database? could it be the import
job that isn't working?

Any idea what this job  would be called?

Answer #3    Answered By: Alison West     Answered On: Apr 27

It started working  again. I changed  a lot of things, but I believe it
was because of the analysis  processing time  period. I extended it. I
also looked to make sure the service  account for my app pool was in
the SSP, which for some reason it wasn't. I'm not sure that adding it
back in changed anything.

Also I added my user account with "Manage usage  analytics"
permissions in Personalization Settings for the SSP

Thanks for everybody's help.

Didn't find what you were looking for? Find more on Usage Analysis Stopped Working Or get search suggestion and latest updates.