Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Undelete web part -> runassystem access denied event

  Asked By: Jena    Date: Mar 26    Category: Sharepoint    Views: 1214

I'm playing with the undelete web part from MS. I'm creating a subdashboard
under Management that can have the document library and the undelete
webpart. I decided to try on a small subsection, so I started the .cmd
script with /r and a time of 10 days. I got an event in event log right as
I started it:

---

Source: Service Control Manager
Category: None
Type: Error
Event ID: 7000
Description:
The RunAsSystem service failed to start due to the following error: Access
is denied

---

I'm logged on via Terminal Services as Domain Admin and Domain Admins are
coordinator of workspace. I've not had any other authentication or access
issues, so I'm wondering if this is a known event? Is it really a problem?
RunAsSystem service is running.

btw, I started the command 2.5 hrs ago and it's still running. The folder
has about 288 subfolders and 3000 files. CPU is just about nil and there's
nothing in the w3svc log showing access to the folders or subfolders.
Should I be worried? Ahh, what I wouldn't give for a truss command in
windows. I do have PStools, so I look in pslist -t:

Name Pid Pri Thd Hnd VM WS Priv
explorer 3304 8 10 236 36056 1416 1816
CMD 2304 8 1 23 11300 40 304
RunAsSystem 2248 8 1 34 16024 44 344

so that I could check that it was the right runassystem running.

Any ideas?

Share: 

 

4 Answers Found

 
Answer #1    Answered By: Daniella Landry     Answered On: Mar 26

You're not running  it on the default document  library dashboard?

 
Answer #2    Answered By: Bo Stafford     Answered On: Mar 26

I haven't installed it on any dashboard yet. I'm just trying out the SetUndelete.cmd script.

I let it run for 6 hours or so and got fed up. Killed it (CTRL-C). Tried it again on just one empty folder. After 1.5 hrs decided to kill it.

I'm sure it's the event  getting logged  -- I'm thinking RunAsSystem isn't allowed over terminal services  and that's my problem. I'll try it Monday when I get in front of the box unless I find another way to test if that's the problem.

I didn't read that adding the web  part to a dashboard was a requirement to set the properties of web folders. I don't want to put it on the default doc lib dashboard because I don't want users seeing it and I don't want to bother with showing/unshowing web part  or security settings. 'course, that doesn't necessarily prevent users from putting it on their on personal dashboards, but it's about ease of use.

 
Answer #3    Answered By: Jocelyn Shelton     Answered On: Mar 26

I ran it as just me instead of the runassystem and got:

Error updating the field
Error Number : -2147024891(0x80070005)
Error Description : Access is denied.
Error Source : Provider

"it" being just part  of setundelete -- cmd /c ConfigureFolder.wsf "url" 14

I still suspect terminal services  but thought I'd document  the error  in case someone else ran into it. Itf I figure it out I'll post again.

 
Answer #4    Answered By: Joey Soto     Answered On: Mar 26

Another update: running  it from the console still gives me the access  denied
event.

You others out there that have successfully installed and used this web
part -- do you get an event  in your log  when you run the SetUndelete.cmd
script? How long does the command  take for an empty folder? seconds?
minutes?

 
Didn't find what you were looking for? Find more on Undelete web part -> runassystem access denied event Or get search suggestion and latest updates.




Tagged: