Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Unable to create site

  Asked By: Karen    Date: Mar 15    Category: Sharepoint    Views: 5798

I keep getting the following error while trying to create a new site:

The virtual server was extended with Windows SharePoint Services, but the following error occurs in creating the default site " http://dev-smk-wss/". Please correct the input and try to create the default site again. Error: Cannot complete this action.

This is a fresh installation of Windows Server 2003 in a test domain (inside 2 virtual PCs). The first virtual PC has AD running on it. The second virtual PC has SQL Server 2005 and Windows SharePoint Services 2003 SP2 installed on it. I have just completed the installation of SQL and WSS. SQL server is running. The AppPool user has the appropriate permissions in SQL Server (Security Administrator and DB Creator). I can find no other data in the logs or event viewer to indicate what failed. The Site DB is created on the SQL server.

Any idea what is causing this error or how I can fix it?



11 Answers Found

Answer #1    Answered By: Jennifer Jones     Answered On: Mar 15

What's the command you are running to get this error?

Answer #2    Answered By: Annie Norris     Answered On: Mar 15

I have tried this from the Central Admin pages, extending onto a virtual  server. I have also tried this from the command line (stsadm, extendvs not sure of the syntax at the moment.)

Answer #3    Answered By: Chadd Hahn     Answered On: Mar 15

So you've extended  the server  onto a virtual  server and then gone to create  a top level team site?

Answer #4    Answered By: Cheryl Kelley     Answered On: Mar 15

No. Part of the process of extention creates a top level site  on the virtual  server. Before the process finishes, I get the error.

Answer #5    Answered By: Sharonda Mcfarland     Answered On: Mar 15

I have just been made aware that I cannot use the UI if I am using AD account creation mode--I need to use stsadm. I tried using stsadm to extend the vs, but I received the same error. Is there another function of stsadm that I should use?

Answer #6    Answered By: Damon Garner     Answered On: Mar 15

I've found this: www.sharepointu.com/.../tm.htm
I will try it today.
(Sorry about spamming the list with all these emails.)

Answer #7    Answered By: Christop Mcfadden     Answered On: Mar 15

Ok, I followed the instructions on the aforementioned site, but I am still having issues. User wssadmin is an administrator on the wss server, has DB Creator and Security Administrator rights in SQL server  (I have since switched to SQL server 2000 SP4), is a member of the sharepoint  administration group, and has been delegated control of the WSSUsers OU in Active Directory. WSSUsers sit at the same level as Users in the AD tree. Below are the commands I am entering:

"C:\Program Files\Common Files\Microsoft Shared\web server extensions\60\BIN\STSADM.exe" -o unextendvs -url "http://dev-smk-wss" -deletecontent

"C:\Program Files\Common Files\Microsoft Shared\web server extensions\60\BIN\STSADM.exe" -o setadminport -port "9999" -admapidname "WssAdminAppPool" -admapidtype "configurableid" -admapidlogin "ida\wssadmin" -admapidpwd "*" -admapcreatenew


"C:\Program Files\Common Files\Microsoft Shared\web server extensions\60\BIN\STSADM.exe" -o setconfigdb -ds "dev-smk-wss" -dn "WssConfigDb" -addomain "ida" -adou "WSSUsers" -adcreation

"C:\Program Files\Common Files\Microsoft Shared\web server extensions\60\BIN\STSADM.exe" -o email -outsmtpserver "dev-smk-ad" -fromaddress "wssadmin@... " -replytoaddress "wssadmin@..." -codepage "65001"

"C:\Program Files\Common Files\Microsoft Shared\web server extensions\60\BIN\STSADM.exe" -o extendvs -url " http://dev-smk-wss" -ownerlogin "ida\wssadmin" -owneremail "wssadmin@..." -ds "dev-smk-wss" -dn "WssSiteDb" -apidname "WssSiteAppPool" -apidtype "configurableid" -apidlogin "ida\wssadmin" -apidpwd "*" -donotcreatesite -apcreatenew

"C:\Program Files\Common Files\Microsoft Shared\web server extensions\60\BIN\STSADM.exe" -o addpath -url "http://dev-smk-wss" -type "wildcardinclusion"

"C:\Program Files\Common Files\Microsoft Shared\web server extensions\60\BIN\STSADM.exe" -o createsite -url "http://dev-smk-wss/Top" -ownerlogin "ida\smk" -owneremail " smk@..." -sitetemplate "STS#0"

The site  creation fails here with an error  message "Access Denied." In the Application Log on dev-smk-wss, I see the fillowing error:
Event Type: Warning
Event Source: Windows SharePoint Services 2.0
Event Category: None
Event ID: 1000
Date: 3/28/2006
Time: 2:39:34 PM
User: N/A
Computer: DEV-SMK-WSS
#1e0046: Adding user "smk4" to OU "WSSUsers" in domain "ida" FAILED with HRESULT -2147024891.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

There are no errors in the logs on the AD server.

Answer #8    Answered By: Victoria Bell     Answered On: Mar 15

I believe this could be a security issue. Check that the account wssadmin has permission to create  users in the OU

Answer #9    Answered By: Cassidy Sharpe     Answered On: Mar 15

I am able to add a user directly to the WSSUsers OU while logged in as wssadmin.

Answer #10    Answered By: Peter Peterson     Answered On: Mar 15

On the last line. The one that was giving me an access denied error, Change the ownerlogin arguement from DOMAIN\username to username.

"C:\Program Files\Common Files\Microsoft Shared\web server  extensions\60\BIN\STSADM.exe" -o createsite -url " http://dev-smk-wss/Top" -ownerlogin "smk" -owneremail " smk@..." -sitetemplate "STS#0"

This works, and created a user "smk6" in the WSSUsers OU and completed the site  creation.

Answer #11    Answered By: Hans Weiss     Answered On: Mar 15

Also, part of the problem was that I was executing the commands logged in as a user that did not have rights to the WSSUsers OU. This was part of the reason that the site  creation was failing.

Didn't find what you were looking for? Find more on Unable to create site Or get search suggestion and latest updates.