Logo 
Search:

MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Template installation confusion

  Asked By: Reuben    Date: Jan 22    Category: MOSS    Views: 1022

I'm trying to get the Fab 40 templates into our test install of MOSS and
I'm just getting more and more confused.

To start with, I found this blog that offers a nice step-by-step
tutorial on how to install templates via the site-admin interface:

vivekthangaswamy.blogspot.com/.../installupload-new-site-temp
lates-in.html

2 questions regarding this:

- the tutorial selects both STP *and* WSP files via the interface. As
far as I can tell, only STP files can be installed this way, correct?

- note screen shot #3 where it shows the 'UPLOAD MULTIPLE DOCUMENTS'. I
don't get that option. Anyone know why? Is there any other way for me ot
upload all 20 STP templates at once or am I just going to have to do
them all one-by-one?

Now, on to the WSP files. I'm going through the readme file that comes
with the templates that shows all the command line options for
installing them via STSADM.

The first thing I need to do is deploy the ApplicationTemplateCore.wsp
solution:

Stsadm -o deploysolution -name ApplicationTemplateCore.wsp
-allowgacdeployment -immediate

I ran that, and then got this warning:

---------------------
The time job for this operation has been created, but it will fail
because the administrative service for this server is not enabled. If
the timer job is scheduled to run at a later time, you can run the jobs
all at once using stsadm.exe -o execadmsvsjobs. To avoid this problem in
the future, enable the Windows SharePoint Services administrative
service, or run your operation through the STSADM.exe command line
utility.
---------------------

The one result of googling this error says that the fix for this
(obviously, in hindsight) is to make sure the 'Windows SharePoint
Services Administration' service is running on the server.

I turned it on (which raises another question...why is this off by
default and should it be turned off after each use for any reason?)

I then ran the command again, and now get this error:

---------------------
A deployment or retraction is already under way for the solution
"applicationtemplatecore.wsp", and only one deployment or retraction at
time is supported.
---------------------

So, that tells me the problem, but not exactly what to do about it.
Anyone know?

Finally, is there any way to install all 20 WSP templates at once via
the command line or will I have to do this all 20 times for each of them
as well?

Share: 

 

7 Answers Found

 
Answer #1    Answered By: Asia Meyers     Answered On: Jan 22

#1. You are correct in that only STP files  can be uploaded via the
site-admin interface.
#2. When uploading the STP files, under the upload  button there
should be a down arrow. Highlight that and you should see the upload
multiple files option  there.
3. The best way to do the WSP's in one quick swoop would be to
create a BAT file  that has all the commands to run  the stsadm.exe.
The two errors you got are ok. Basically what happened is that the
first error  stated that the deploy  would not take effect immediately,
then when you tried to redeploy, it saw that you had already run the
command and it was waiting to finish the deploy. I would finish the
stsadm.exe commands and deploy the ApplicationCore template  then do
an IISRESET. This will deploy the template and then you should be
able to deploy the rest. If you put the -immediate tag at the end of
the addsolution command  it will only require an IISRESET to finish
the install.

 
Answer #2    Answered By: Shelley Reese     Answered On: Jan 22

> #2. When uploading the STP files, under the upload  button there
> should be a down arrow. Highlight that and you should see the upload
> multiple files  option there.

That's what's odd. I don't get that option. When I click the down arrow,
I just get one being the 'Upload Document' option. Odd.

> 3. The best way to do the WSP's in one quick swoop would be to
> create a BAT file  that has all the commands to run  the stsadm.exe.

I've never done that. I assume that's not really a Sharepoint centric
thing, but just a command  line thing? I'll do some googling...

 
Answer #3    Answered By: Omar Arnold     Answered On: Jan 22

That is odd that you don't have the upload  multiple option...

The second... if you create a text file  in notepad that has the
commands for the stsadm.exe processing and then save it with a .bat
file extension, you can then just run  one command  and everything will
run happily.

 
Answer #4    Answered By: Christen Roberson     Answered On: Jan 22

I have created  a blog  post on my blog that explains and has a copy of the
BAT files  that I created to automate the install. go to
woodssongproductions.spaces.live.com/default.aspx to view the blog
entry.

 
Answer #5    Answered By: Faith Delgado     Answered On: Jan 22

The only reason not to see the multiple files  selection is if you are not
running Office 2003 or 2007. Anything less than these versions will cause
you not to see the selection option. The other reason would be that your
SharePoint is not recognizing the Office version you are using (would be
odd, but plausible). How are you accessing the sharepoint  platform? If you
are running  through a lot of firewalls and ISA's or some other control
mechanism, it is highly possible that it may cause this problem  (more
supposition here than known fact or experience).

 
Answer #6    Answered By: Amrita Durgude     Answered On: Jan 22

I was doing all of this via remote desktop on the
server itself. Office 2007 was never installed  on the server. Sure
enough, If I do this from my own machine, the 'upload multiple  files'
option appears.

 
Answer #7    Answered By: Maricela Conway     Answered On: Jan 22

Using a non-IE browser will do it too. Presumeably because a browser like
Firefox doesn't talk to Office directly even if it's installed.

 
Didn't find what you were looking for? Find more on Template installation confusion Or get search suggestion and latest updates.