Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Subscription Notifications

  Asked By: Anita    Date: Jan 19    Category: Sharepoint    Views: 862

Does anybody know how I can modify the links in the subscription
notification email? All my links are using the NetBIOS name and not the
FQDN to my server.

Share: 

 

24 Answers Found

 
Answer #1    Answered By: Chirag Gupte     Answered On: Jan 19

That was the same problem for me ; I find the only solution as I
manually modify  the template file and append the netbios name with the
FQDN.

 
Answer #2    Answered By: Vivek Patel     Answered On: Jan 19

You can find it on spsfaq.com:

SPSFAQ060147 - How can I specify the external FQDN for subscriptions?
Open Web Storage System Explorer. (Look in the SPSFAQ Links section)
Connect to http://NetBIOS_name/SharePoint Portal Server/workspaces:
Type username.
Type password.
In Web Storage System URL, type http://NetBIOS_name/SharePoint Portal
Server/workspaces. For example, to connect to a server  named AdvWks,
type http://AdvWks/SharePoint Portal Server/workspaces.
Click the node for http://NetBIOS_name/SharePoint Portal
Server/workspaces to display its schema detail view. Right-click in
Detail View, and then click Add Property.
In Add Property:
In Name, type urn:schemas-microsoft-com:publishing:ServerUrl

IMPORTANT: The property name is case-sensitive. Type the property name
exactly as specified. In Datatype, select string.

If you always want to use the NetBIOS name in e-mail, in Value, type
http://NetBIOS_name. If you always want to use the internal FQDN in
e-mail, type http://internal_FQDN. If you always want to use the
external FQDN in e-mail, type http://external_FQDN.
Click OK.
Close Web Storage System Explorer.
Restart MSSearch. To do so:
On the Start menu, point to Programs, point to Administrative Tools, and
then click Services.
Right-click Microsoft Search, and then click Restart.

 
Answer #3    Answered By: Rajul Shah     Answered On: Jan 19

Check Page 22 of the Extranet deployment whitepaper. It explains how to do. The
Extranet tool is supposed to do it but I have seen instance where it doesn't.

Basically using the WSS Explorer you can modify  the Property
urn:schemas-microsoft-com:publishing:ServerURL to match your FQDN. Make sure to
change this at the top workspace level

 
Answer #4    Answered By: Karan Hosagrahara     Answered On: Jan 19

> Basically using the WSS Explorer you can modify  the Property
urn:schemas-
> microsoft-com:publishing:ServerURL to match your FQDN. Make sure to
change
> this at the top workspace level

And make sure it's urn:schemas-microsoft-com:publishing:ServerUrl (not
urn:schemas-microsoft-com:publishing:ServerURL), otherwise it won't work.

 
Answer #5    Answered By: Elise Weber     Answered On: Jan 19

I have a problem with subscription  notifications,
it only happens one time then stops working, the only
way to fix this problem is to delete the subscription
and recreate it, but only one notification will be
sent before it stops working again? I have verified
the SMTP local service and scheduled tasks, I even
changed the default utf-8 unicode character set to
iso-8859-1 western to match what the IMS character
setting is on my Exchange server, does anyone have any
suggestions?

 
Answer #6    Answered By: Alton Vance     Answered On: Jan 19

I just setup a server  with one portal site and I have not been able to
get the subscription  notifications to work. I have tried using the IP
address and the NetBIOS name of the SMTP server and nothing works. My
subscription web part gets updated with any changes but no email
notifications. I did use the PLEX tool to disable subscription
notifications during reboot. I thought this might be causing the problem
so I deleted it but still no emails. Does anybody have any idea what is
happening?

 
Answer #7    Answered By: Sydney Lewis     Answered On: Jan 19

There is no "disable subscription  notification during reboot"
setting. There is only "disable subscription notifications". You
need to disable notifications, reboot the server  and then re-enable
them.

 
Answer #8    Answered By: Jayme Raymond     Answered On: Jan 19

So the correct procedure is: 1) use the PLEX tool to add that one item
to disable the notifications  2) reboot the server  and 3) use the PLEX
tool and delete that item for disabling notifications? Is this right?

 
Answer #9    Answered By: Devika Bellad     Answered On: Jan 19

Correct. You should also be able to just change the value to false

 
Answer #10    Answered By: Diego Paul     Answered On: Jan 19

One more question, just making sure that I'm adding that item in the right place
when using the PLEX tool. When I click the refresh button, the left window
displays the structure of the portal. Which one do I select to add the item to
disable notifications? Because by default, the right window is blank.

 
Answer #11    Answered By: Denis Cantrell     Answered On: Jan 19

You can add it at the server  level or the workspace level (I think)
try it both places. Be sure your not using for the url
http://server/workspace. Use "http://server/sharepoint portal
server".

 
Answer #12    Answered By: Sarita Patel     Answered On: Jan 19

I've tried all of the below procedures and my notifications  are still
not coming through..

I followed the procedure:

Open the PLEX tool
Navigate to http://servername/sharepoint portal server/
Add the field (urn:schemas-microsoft-
com:publishing:DisablesubScriptionNotifications) under "workspaces"
Also added the field under "applications" and "myportalname"
Set the field to TRUE and adboolean
Reboot the server

I even found some more advice on another site about giving the SMTP
server a FQDN, and nada..any more suggestions?

 
Answer #13    Answered By: Elias Cannon     Answered On: Jan 19

Yes it works for the server  level and workspace level

 
Answer #14    Answered By: Kartik Athani     Answered On: Jan 19

You have to keep in mind that this tool is used to DISABLE subscription
notifications. The reason why we are using this tool is because every
time you reboot the server, SPS does a full index and therefore it sends
out subscription  notifications eventhough there are no changes to the
documents. You use this tool to disable the notifications, reboot the
server and then use this tool to either delete the item or change it to
FALSE. If you leave this item as is, then no subscription notifications
will go out.

 
Answer #15    Answered By: Ira Knox     Answered On: Jan 19

DisablesubScriptionNotifications should be DisableSubscriptionNotifications

This is case sensitve

and property should be set to false not true

You do not have to reboot the server  but if you want to changes to take
place immediately, restart the mssearch service

 
Answer #16    Answered By: Divyesh Hurkadli     Answered On: Jan 19

I'm wondering if anybody can shed some light on this issue.

We currently host several portal sites here with our own domain, i.e.,
abc.domain.net. The domain is running Windows 2000 with Active Directory
and Exchange 2000. I created users and associated each user with a
contact because this way when they get emails at
testuser@..., it gets forwarded to their work email  account.
When they create subscriptions and put in their work email address for
notifications, they don't get notified. But when they put in the email
address of the domain where the server  is residing (i.e.,
testuser@...), then they do get emails. I also tried putting
in a yahoo email address and it didn't work.

Is SharePoint not aware of any other email addresses besides the one
that is on the domain?

Also, I'm trying to work around this problem by modifying the
CreateSubscription.asp to automatically populate the domain email
address, but have not been successful. Has anybody tried doing anything
like this?

 
Answer #17    Answered By: Darryl Nguyen     Answered On: Jan 19

Subscriptions from sharepoint can send to any email  address you enter on
the subscription  properties. I've tested this many times -- ie, I
create a subscription that sends to my yahoo address.

I would expect that whatever smtp server  you're forwarding to (or if
you're using SMTP service directly on your own box, then your box) isn't
configured to forward mail to anything but your domain.

Are you pointing your smtp server properties in sharepoint to your own
server (the sharepoint server) or to an external machine like
smtp.domain.net?

 
Answer #18    Answered By: Tom Pruitt     Answered On: Jan 19

I have an exchange server  in this domain too. I'm able to send out from
the exchange server with no problem. I have the SharePoint server
pointing to this exchange server.

 
Answer #19    Answered By: Sammie Lancaster     Answered On: Jan 19

Does your exchange server's log show anything about complaining about
relaying denied? I'm a sendmail guy more than Exchange, so I don't know
what else to tell ya other than slap a packet sniffer on the port and
see if sharepoint's sending it out. That would be my next step.

 
Answer #20    Answered By: Aron Kirk     Answered On: Jan 19

Sharepoint subscriptions relyies on SMTP. First check what SMTP server
is configured for Sharepoint (Thru MMC)

Once you figure this out, troubleshoot the SMTP server  to see why it
cannot send email  to other domain. One other way to achieve this is to
point Sharepoint to a different SMTP server

 
Answer #21    Answered By: Hailey Clark     Answered On: Jan 19

We are running SPS SP1 and I would like to change the format of the
"From" email  address used in subscription  notification emails.

SPS by default uses the address workspacename@servername but I want the
"From" address to be workspacename@....

What file/script do I need to amend?

 
Answer #22    Answered By: Nisarg Shahane     Answered On: Jan 19

A google groups search of

sharepoint subscription  notification change

should give you a good answer. The first hit says

--

There is a file called results.xsl in folder:

http://server/workspace/system/Subscriptions/Templates

This XSL renders the notifcation mail.

You will need to map an m: drive to access it though use:

subst m: //./backofficestorage/localhost/sharepoint portal server

on the server  and access the file above through windows explorer

 
Answer #23    Answered By: Naimish Misra     Answered On: Jan 19

I have used results.xsl in the past to change the format of the
subscription notification email.

Is the FROM address for the email  specified in this file - I cannot find
the piece of code that might do this?

Perhaps the FROM address is specified when the command is issued to send
the email - where is this code and can I change it?

Any help is appreciated. We are evaluating a new piece of software which
filters out spam email and our subscription  notifications are being
blocked because the FROM address syntax is invalid i.e. does not include
a domain.

 
Answer #24    Answered By: Terence Thornton     Answered On: Jan 19

I do not know if you can just change the address. I guess the address is
generated in some way.

After all, we implemented the Internal FQDN scenario on our SPS and the from
address include the domain name.

You may refer to the ExtrScen.doc in the SPS package.

 
Didn't find what you were looking for? Find more on Subscription Notifications Or get search suggestion and latest updates.