Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

STSADM import problem

  Asked By: Jessika    Date: Nov 01    Category: Sharepoint    Views: 4058

I'm attempting to export a WSS v3 subsite into a
top-level site of the same name. The export seems to
work fine but then I run the import I get a fatal
error. The command line I'm using is hereL:

stsadm -o import -url
http:/***/sites/it-annual-planning
-includeusersecurity -updateversions 1 -filename
it.dat

Here's the error message that I receive:

[3/12/2008 4:14:53 PM]: Error: The file cannot be
imported because its parent web
/sites/it-annual-planning/IT-Annual-Planning does not
exist.
[3/12/2008 4:14:53 PM]: FatalError: The file cannot
be imported because its parent web
/sites/it-annual-planning/IT-Annual-Planning does not
exist.
at
Microsoft.SharePoint.Deployment.FolderSerializer.GetParentWeb(SerializationInfoH\
elper
infoHelper, ImportObjectManager objectManager)
at
Microsoft.SharePoint.Deployment.FolderSerializer.SetObjectData(Object
obj, SerializationInfo info, StreamingContext context,
ISurrogateSelector selector)
at
Microsoft.SharePoint.Deployment.XmlFormatter.ParseObject(Type
objectType, Boolean isChildObject)
at
Microsoft.SharePoint.Deployment.XmlFormatter.DeserializeObject(Type
objectType, Boolean isChildObject, DeploymentObject
envelope)
at
Microsoft.SharePoint.Deployment.XmlFormatter.Deserialize(Stream
serializationStream)
at
Microsoft.SharePoint.Deployment.ObjectSerializer.Deserialize(Stream
serializationStream)
at
Microsoft.SharePoint.Deployment.ImportObjectManager.ProcessObject(XmlReader
xmlReader)
at
Microsoft.SharePoint.Deployment.SPImport.DeserializeObjects()
at Microsoft.SharePoint.Deployment.SPImport.Run()

Share: 

 

10 Answers Found

 
Answer #1    Answered By: Shara Johnson     Answered On: Nov 01

How did you create /it-annual-planning? For this to work you have to create an
empty site  collection first like this:

Stsadm “o createsite “url http:/***/sites/it-annual-planning “ownerlogin
domain\user “owneremail user@...

The key is not to apply a temple. Then try the import. That should work.

 
Answer #2    Answered By: Victoria Bell     Answered On: Nov 01

That's the syntax that I used to create the top level
site. I just deleted the site  and recreated it just
to be sure but the error  is still occuring. The
strange part that I noticed is that for some reason
it's looking for a subsite  called it-annual-planning
underneath the it-annual-planning top-level site.

 
Answer #3    Answered By: Cassidy Sharpe     Answered On: Nov 01

Nope, just normal sites. I'll have to try it without saving the previous
versions of documents. Some of those documents had over 100 versions included.
I'm thinking that it just craps out after a while, because it manages to go
through the process of importing users.

 
Answer #4    Answered By: Linda Mason     Answered On: Nov 01

Totally stepping into this blind and with no expertise but...

Back when we were porting a WSS v2 site  to WSS v3, I seem to remember something
about a child site must always be a child site on restore. Does that ring
anyone's bell?

 
Answer #5    Answered By: Hans Weiss     Answered On: Nov 01

Did you look at my screenshot? It works in v3/MOSS. I've done it multiple
times, even demoed it during my STSADM session in Barcelona. You're right
though, V2 wasn't as understanding about it.

 
Answer #6    Answered By: Alison West     Answered On: Nov 01

I'm wondering if his problem  has to do with the switch that he did on the
import to maintain security? I know you can Import/Export a basic site  from
child to Root, but I could see problems with trying to take the specific
security set at the child level and apply that to the root.

 
Answer #7    Answered By: Freddy Heath     Answered On: Nov 01

I'm starting to wonder if I wasted my time posting that screenshot. I used
the “includesecurity switch on my import  and it worked. As a matter of fact I
just hit up arrow until I got to the export  command, changed "export to
"import" and took about the versions switch. They both included security.

 
Answer #8    Answered By: Joanna Dixon     Answered On: Nov 01

I looked at it.

I love the green on black. (I actually worked on a 5250 terminal, but that is a
different discussion list.)

 
Answer #9    Answered By: Justine Barrera     Answered On: Nov 01

I also looked at it.

But I didn't notice that the exported site  was a child site while it was
imported into the root of a new named site collection in the root of the sites
wildcard managed path.

 
Answer #10    Answered By: Sharonda Mcfarland     Answered On: Nov 01

Just for the sake of my sanity, I re-tried the
identical operation against another subsite  and it
worked fine.

I ran a second attempt against the original subsite,
this time only capturing current document versions and
it still failed with the original error. I guess I'll
have to call PSS on this one to see if it's a bug of
some kind.

I took a look at the screenshot. The only difference
in our environment versus yours is that this is a
wss-only server with a single top level site. This
site has its own host header so full url being
affected is http://wwit/it-annual-planning.

 
Didn't find what you were looking for? Find more on STSADM import problem Or get search suggestion and latest updates.




Tagged: