Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Stsadm

  Asked By: Aiesha    Date: Jun 12    Category: Sharepoint    Views: 1627

Running Windows Sharepoint Services 2.0 on Server A and SQL 2000 database on Server B. At the command prompt, I run the following two commands;

cd \Program Files\Common Files\Microsoft Shared\web server extensions\60\BIN

stsadm -o enumsites -url http://Sever A

I receive “Command line error” followed by a list of possible stsadm commands to use. Can anyone direct me in the correct usage of stsadm?

Share: 

 

10 Answers Found

 
Answer #1    Answered By: Kristie Hardy     Answered On: Jun 12

Are you typing it with a space between http://server and the A like it is below?
If so, that will cause you to get the STSADM usage.

 
Answer #2    Answered By: Faith Delgado     Answered On: Jun 12

Looks fine to me
Before you enter the stsadm  command does your command prompt say
C:\ Program Files\Common Files\Microsoft Shared\web server  extensions\60\BIN?
Also, as Todd says, if you have spaces in the site name you need to encapsulate it in quotes
i.e. stsadm –o enumsites –url “http://Server A”
Also, you may want to do a
C: <return>
Before your cd command to make sure you are referencing the c drive!
Other than that I cant see a problem

 
Answer #3    Answered By: Alisha Itagi     Answered On: Jun 12

It's because of the space between the server  and the A in the URL name.
Try enclosing the server name with double quotes ("), as in:-

stsadm.exe -o enumsites -url "http://Server A"

 
Answer #4    Answered By: Judy Pittman     Answered On: Jun 12

I also note that your command

cd \Program Files\Common Files\Microsoft Shared\web server  extensions\60\BIN

tries to change directories for names with spaces in so will likely fail as it will see the command as “cd \Program” so you may want to encapsulate that whole command in speech marks also (I.e. cd “c:\ Program Files\Common Files\Microsoft Shared\web server extensions\60\BIN”) or cd each folder one after the other and make sure your command prompt says

C:\ Program Files\Common Files\Microsoft Shared\web server extensions\60\BIN

Before you try to use stsadm



 
Answer #5    Answered By: Christian Waters     Answered On: Jun 12

Would having a virtual server  make a difference? Within the Sharepoint Central Administration app, it’s defined as:

Virtual Server Name: PMO

URL: http://holt/

The content database server is elkhorn. It’s accessed via Internet Explore through http://pmo/PMO/default.aspx link.

When I enter stsadm  -o enumsites -url http://holt/, I receive “Command line error”. I there a setting in the Sharepoint Central Administration that can point me in the right direction?

 
Answer #6    Answered By: Virendar Bahudur     Answered On: Jun 12

Try including the virtual path as well: -url http://ServerA/sites/...

 
Answer #7    Answered By: Sierra Beck     Answered On: Jun 12

What happens if you leave the trailing slash off the url when you run the
command ?

 
Answer #8    Answered By: Elisabeth Walsh     Answered On: Jun 12

Try stsadm  -o enumsites -url "http://Sever A"

 
Answer #9    Answered By: Bhavesh Doshi     Answered On: Jun 12

At the command prompt, I ran the follwing two commands.

cd c:\Program Files\Common Files\Microsoft Shared\web server  extensions\60\BIN

stsadm -o enumsites -url http://holt

I received the following,

<SitesCannot complete this action

<Please try again

How can I verify that my userid (which is set to a roaming profile) has access/permission to our SQL server (Server B)?

 
Answer #10    Answered By: Elisa Santos     Answered On: Jun 12

Did you ever get an answer to your question?

I'm having a similar problem.

Up until a week or so ago my SPS 2003 portal was running  fine. Then I
began to notice some sites not appearing in search results.

I tried trouble shooting it, even called Microsoft. We ended up with
some major problems, like now my Index doesn't even see my server  at all.

I just tried stsadm  and I get the same

<SitesCannot complete this action

Error message.

This might explain why my index server can't see the portal to index
the sites... Maybe there is something more serious here?

I've verified permissions on the account at both the server level and
the DB level.

Yet it seems like it can't connect as if it was a permissions issue?

I can access sites on my portal fine, it's just indexing and stsadm
which are not working?

Any kind souls reading this have ideas?

 
Didn't find what you were looking for? Find more on Stsadm Or get search suggestion and latest updates.




Tagged: