Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

SSl is working

  Asked By: Umesh    Date: Oct 11    Category: Sharepoint    Views: 943

After a lot of time and effort, it seems like we got ssl working. Follow every
step in the "Deploying Microsoft SharePoint Portal Server 2001 Across an
Extranet".

If you issued your own certificates, you have to install the full chain of
certificates, i.e. install the certificate you created AND the root certificate
(thisis the one that was created when you installed your certificate server) on
the sps server and on the clients.

Share: 

 

10 Answers Found

 
Answer #1    Answered By: Emily Clark     Answered On: Oct 11

Thanks for the update on SSL working  with SharePoint. We are going to be
undertaking a SharePoint Portal Server extranet project where security is
the number one priority. Are there any other good sources of information on
SPS security for extranet implementations besides the "Deploying .. Across
an Extranet" available?

 
Answer #2    Answered By: Alycia Everett     Answered On: Oct 11

I just stumbled on a problem here with ssl. I followed all the steps in
the Extranet ... white paper and everything is OK until I want to access
the dashboard via https. It's working  via http and also the first page
https://fqdn is working. But when I go to https://fqdn/workspace I got a
Proxy error. The text is following:

An unexpected error occurred.
An error occurred while accessing the dashboard. This error may be
caused by the proxy server  settings for the dashboard. Contact your
server administrator. If you are a server administrator, configure the
proxy server settings by using the proxycfg utility. Consult the product
documentation and the readme for more information about configuring the
proxy server settings. Important: You must configure the proxy server
settings for the dashboard even if you are not using a proxy server. (1)
Object or data matching the name, range, or selection criteria was not
found within the scope of this operation.
-2147217895
Provider

Any idea why is that? Also the normal, intranet site is working
very well.

Any help would be greatly appreciated!

 
Answer #3    Answered By: Kaila Hahn     Answered On: Oct 11

I resend this message. Maybe someone have an idea about this!!!

I just stumbled on a problem here with ssl. I followed all the steps in
the Extranet ... white paper and everything is OK until I want to access
the dashboard via https. It's working  via http and also the first page
https://fqdn is working. But when I go to https://fqdn/workspace I got a
Proxy error. The text is following:

An unexpected error occurred.
An error occurred while accessing the dashboard. This error may be
caused by the proxy server  settings for the dashboard. Contact your
server administrator. If you are a server administrator, configure the
proxy server settings by using the proxycfg utility. Consult the product
documentation and the readme for more information about configuring the
proxy server settings. Important: You must configure the proxy server
settings for the dashboard even if you are not using a proxy server. (1)
Object or data matching the name, range, or selection criteria was not
found within the scope of this operation.
-2147217895
Provider

Any idea why is that? Also the normal, intranet site is working
very well. I must mention that we use ISA Firewall on a different
server. The proxy is configured accordingly.

Any help would be greatly appreciated!

 
Answer #4    Answered By: Ada Sosa     Answered On: Oct 11

This occurs if the securebindings are not properly
set. Try the following command
cscript adsutil.vbs set W3SVC/iii/securebindings
"xxx.xxx.xxx.xxx:443:fqdn name" to set the bindings
again.

e.g.
W3SVC/3/securebindingd
"1.1.1.1:443:myportal.mysite.com"

this should sort out the problem...

 
Answer #5    Answered By: Cheyenne Lewis     Answered On: Oct 11

I've done this, but I keep getting this warning:
Instance 3 has invalid secure binding descriptor
xxx.xxx.xxx.xxx:443: myportal.mysite.com (host name ignored).

I have no other instance with ssl.

Any ideas?

 
Answer #6    Answered By: Liana Alston     Answered On: Oct 11

try the proxycfg tool in the sharepoint  directory bin its a command line tool
which allows you to switch on using https on sharepoint

i think the switch is -p
for more reading carries a good guide on this
support.microsoft.com/default.aspx
ta eve

 
Answer #7    Answered By: Daamodar Kolhe     Answered On: Oct 11

I'm having the same problem. Got sharepoint working  on a test box and
started usinging it. Now we buy a new server  to run it on, setup everything
using the extranet script and ssl  just won't work. The IIS bindings is the
same on both systems with the exception of the IP address:

C:\Inetpub\AdminScripts>cscript adsutil.vbs get w3svc/2/serverbindings
Microsoft (R) Windows Script Host Version 5.1 for Windows
Copyright (C) Microsoft Corporation 1996-1999. All rights reserved.

serverbindings : (LIST) (1 Items)
"10.101.3.10:80:sharepoint.mydomainname.com"

Both servers are setup the same, both even have the same directpry
structure, proxy cfg, etc even the same name (new one if behind a firewall
so block its name resolution to prevent it from causing a conflict on the
network and have its IP in a host file on my pc to test it)

 
Answer #8    Answered By: Emerson Franks     Answered On: Oct 11

I managed to finally get mine working

support.microsoft.com/default.aspx

I deleted the msxlm3.dll and reinstalled msxml3sp2.

 
Answer #9    Answered By: Ned Storm     Answered On: Oct 11

The "deploying .. Across extranet" is about is....with this document and knowing
that you must install the root certificate as well, you cannot go wrong.

 
Answer #10    Answered By: Myron Calhoun     Answered On: Oct 11

There's also 10 pages dedicated to this in the Sharepoint manual.

 
Didn't find what you were looking for? Find more on SSl is working Or get search suggestion and latest updates.




Tagged: