Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

SSL and document searching

  Asked By: Colt    Date: Jun 10    Category: Sharepoint    Views: 684

I have a secure portal site with a couple top-level sites. We have a
problem with search results when searching the top-level sites
document library. While appropriate documents are returned, they are
prefaced http and cannot be accessed. When the user changes the
preface to https everything appears fine.

Share: 

 

4 Answers Found

 
Answer #1    Answered By: Matt Prince     Answered On: Jun 10

Make sure you have your alternate portal  URLs set correctly in Central
Admin -> Portal site  and Virtual Server Configuration -> Configure
alternamte portal site URL for....

 
Answer #2    Answered By: Brooks Bond     Answered On: Jun 10

After adding the "S" to the hhtp in the alternate portals. I
started a crawl and went my merry way.

When I came in this morning, the crawl had paused with a "disk
full" message. I'm pretty new to this so it took me a while to figure
out that SPS was using C: for temp storage. Sure enough it was full.

Long story short: the temp folder wasn't much, but some of the
alphanumeric stew folders were. I deleted them all (I have three
portal sites) from DATA, thinking SPS would recreate them. It seems to
have, but only two of the three site  are doing real crawls. The third
(the one I changed yesterday) crawls for an instant, and goes back to
idle. 0 docs, 0 megs, but the gathere log reports successful crawls.
The folder it claims to be using for data is in fact created.

 
Answer #3    Answered By: Gregg Wilkinson     Answered On: Jun 10

Couple of things.

First, use the catutil.exe and move your indexes and temp path to
another drive, that should help you c:\ issue. Check out this blog:

bes.xs4all.nl/blog/archive/2004/07/18/258.aspx

Second, verify you have complex urls included in your crawls.

https://yourportal/default.aspx -> Site Settings -> Configure Search
and Indexing -> Content Indexes Section....Non_Portal_Content ->
Manage rules to exclude and include content -> verify your included
paths have 'Include complex URLS (conatin a ?)

I always start a Full Index after this. Good luck.

 
Answer #4    Answered By: Darrel Sexton     Answered On: Jun 10

T read the blog you referred to, and will try moving them when/if I
get this resolved; I also implemented your second suggestion.

I got rid of some other things on C: and right now have a few Gb free.

It seems odd to me that 2 of the 3 portals are crawling fine  right
now, but the third, the one whose crawls died last night, still
reports 0 files in 0 Mb. The datafile is back in the DATA folder, and
the sps.ebd file has grown to 10 Mb. It appears  that the gatherer just
doesn't want to look at it.

 
Didn't find what you were looking for? Find more on SSL and document searching Or get search suggestion and latest updates.




Tagged: