Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

SPS2003 - How to perform backup of individual sub-area

  Asked By: Wendy    Date: Mar 29    Category: Sharepoint    Views: 1639

I have a SPS2003 sub-area that’s outlived its usefulness, its content is very stale, and yet I don’t want to delete it outright. I’d like to preserve it individually like a wss backup via stsadm, delete the original sub-area, then restore it as needed (not likely).

I tried:

stsadm.exe –o backup http://<portalname>/c<number>/<subareaname> –filename c:\whatever.dat

but this fails with the following error:

The specified URL is not a top-level Web site. The backup and restore operations work only for top-level Web sites. Enter the URL for a site to try the operation again.

Is individual sub-area backup available with OOB SPS\WSS admin tools?

Share: 

 

9 Answers Found

 
Answer #1    Answered By: Kalyan Pujari     Answered On: Mar 29

Try smigrate -w http://<portalname>/c<number>/<subareaname> -f subareaname.fwp

 
Answer #2    Answered By: Isidro Berger     Answered On: Mar 29

I tried smigrate and got the following error:
C:\Program Files\Common Files\Microsoft Shared\web server
extensions\60\BIN>smigrate -w "http://<portal>/C<number>/<subareaname
with embedded spaces>" -f c:\spsbkups\subareas\<subareaname with
spaces removed>.fwp
28 Mar 2006 10:17:38 -0500 Site collection opened
28 Mar 2006 10:17:38 -0500 Site opened
Progress: Starting Backup.
Progress: Opening service >/C<number>/<subareaname with embedded
spaces>.
Progress: Finished open service
http://<portal>/C<number>/<subareaname with embedded spaces>
Progress: Server version is: 6.0.2.5523
Progress: Fetching Manifest
Progress: error  getting manifest for
http://<portal>/C<number>/<subareaname with embedded spaces>" (fatal)
Progress: You are not authorized to perform  the current operation.
28 Mar 2006 10:17:39 -0500 ERROR (possibly fatal):
ERROR: 6553609 You are not authorized to perform the current
operation.

28 Mar 2006 10:17:39 -0500 Site closed
28 Mar 2006 10:17:39 -0500 Site collection closed

I got the same "You are not authorized to perform the current
operation" error if I ran with my identity or my sps service identity
(both of which are local admins).

 
Answer #3    Answered By: Schuyler Le     Answered On: Mar 29

Try this site. It was a very big help in my case. blogs.msdn.com/.../490074.aspx

 
Answer #4    Answered By: Kristina Cox     Answered On: Mar 29

www.microsoft.com/.../fp03sps.mspx

sounds like an administrator disabled backup. look for wdfbackup in that document and you will see how it was disabled and how to enable it so you can back up subsites.

 
Answer #5    Answered By: Kalyan Pujari     Answered On: Mar 29

Using SharePoint Explorer, I saw that the sub-area  template was
SPSTOPIC, so per the link below I modified onet.xml in C:\Program
Files\Common Files\Microsoft Shared\Web Server Extensions\60
\Template\1033\SPSTOPIC\XML to remove wdfbackup from
DisableWebDesignFeatures. I then ran iisreset (to reload the new
onet.xml), tried the smigrate command, but got the exact same error.

 
Answer #6    Answered By: Willard Valenzuela     Answered On: Mar 29

im thinking that using frontpage to backup  a portal area isnt supported :(

smigrate is only for WSS? i just want to get the final word on that.. can anyone confirm?

 
Answer #7    Answered By: Allison Stewart     Answered On: Mar 29

I have run into this situation with a client about 4 months ago. I
ended up on the phone with SPS PSS and they told me at that time they do
not have a way to backup  individual sub-areas.......( i know I couldn't
believe it either!!). To answer your question about FP backing up a
portal area this is most definitely unsupported. SMIGRATE is only for
backing up individual  WSS sites  only but because of its Size limit I use
STSADM tool for all my individual backups.

I hope this clarifies somethings for you.

 
Answer #8    Answered By: Emmett Hyde     Answered On: Mar 29

That’s correct, you cannot backup  portal area neither with Frontpage, smigrate or stsadm. Only option is to use 3rd party product like AvePoint

 
Answer #9    Answered By: Michelle White     Answered On: Mar 29

Try logging on the server itself using the service account and running
smigrate.

 
Didn't find what you were looking for? Find more on SPS2003 - How to perform backup of individual sub-area Or get search suggestion and latest updates.




Tagged: