Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

SPS web.config - "identity impersonate" problem?...

  Asked By: Scot    Date: Mar 14    Category: Sharepoint    Views: 1929

1. We are in a problem of running SPS site after deploying our
webpart. Its throwing some web.config error(Server Error in
'/_layouts' Application).
Afterwords, I just set the custom error to "off". <identity
impersonate="false" />
The first time the SPS site works perfectly fine. If you open a new
browser and try accessing the portal site gives "Catastrophic
failure."
Again if I set <identity impersonate="true" /> gives the web.config
error(same above application error) like that it is
iterating the processes. when somebody tries to access the sps site,
even though they have permission(administrator) to access the site,
its throwing
'Server Error in '/_layouts' Application'.

Why the result is not consistant. and why I am getting this
inconsistent result after deploying my webpart? Please can
anybody gives some tips to solve this issue?

Share: 

 

2 Answers Found

 
Answer #1    Answered By: M Juarez     Answered On: Mar 14

How did you install the webpart? was it using the command line?? was it installed into the GAC or was it a executable??

Can you add the web  part to another area without getting the same error??

 
Answer #2    Answered By: Marty Mcdowell     Answered On: Mar 14

I have deployed the webpart  through STSADM command line tool.
yes very first time  after set  to impersnate to false it perfectly
works fine. if I close the browser and open  new browser gives error.
after building the webpart, I created a CAB file.

No its just BIN version webpart. I just used -Force parameter along
with STSADM.

 
Didn't find what you were looking for? Find more on SPS web.config - "identity impersonate" problem?... Or get search suggestion and latest updates.




Tagged: