Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

SOAP Errors

  Asked By: Angie    Date: Mar 05    Category: Sharepoint    Views: 4343

I can't get spsearch.asmx web service to work and suddenly SharePoint
Designer started throwing me an error. I wonder if they are related???
Here are the errors

spsearch.asmx

SoapException: Server was unable to process request. ---> Attempted to
perform an unauthorized operation.

SharePoint Designer:

soap:ServerServer was unable to process request. ---> An unexpected
error occurred while opening this page. For assistance, contact your
site administrator.

I tried recycling the app pool and resetting IIS. I went as far as
rebooting the server.

Nothing works.

Share: 

 

5 Answers Found

 
Answer #1    Answered By: Deonte Stein     Answered On: Mar 05

You didn't accidentally remove the permission in a Web App policy, did
you? I did this awhile back by mistake...

 
Answer #2    Answered By: Stephon Valentine     Answered On: Mar 05

I get the same error  using the sharepoint  Query Web service  Test Tool

I thought maybe the error was I had to run it on the local server.

I tried RunAs and ran the tool as the search service account specific to
the shared Service Provider. Which is also the service account for the
app pool.

I tried to run it using the farm search service account.

I tried to run it using the farm administrator  account.

 
Answer #3    Answered By: Leif Cardenas     Answered On: Mar 05

Okay, I fixed the problem, but I don't understand why.

"SoapException: Server was unable  to process  request. ---> Attempted to
perform an unauthorized  operation."

This was because although I had the Authentication Provider for
application search.byui.edu set to Anonymous, I had not set the site
collection's Anonymous access.

As soon as I did, searches started  to work  for me from my windows
system, where I was authenticated as myself (a site collection owner)

My colleague tried, and it did not work for him, but he did get a new
error: "Unauthorized"

Now I'm confused why I would get an unauthorized operation  exception,
and then anonymous fixed that but they are still unauthorized?

I added to the site collection visitors "All authenticated users" and
now it works  just fine for everybody.

Do these errors  divulge I should have been using my application at
ssphost.byui.edu instead of the search site collection?

Should I have added the IUSR_SERVER user instead of all users since it
is the anonymous access user?

Should I have just added the Search Service user to the site collection
visitors group?

Thanks for all your help everyone

 
Answer #4    Answered By: Jasper Hatfield     Answered On: Mar 05

I created a new farm and two new shared service  providers, and
thought I had the procedure down for providing search over a web
service.

I can access the search web  service from
primaryapp.byui.edu:80/_vti_bin/spsearch.asmx but I wasn't sure this
was the correct place for it. since spsearch seems to give the same
results no matter the URL as long as the app  is within the same
shared service provider I thought I would try
https://ssp.byui.edu:port/_vti_bin/spsearch.asmx.

I still get the error  "Attempted to perform an unauthorized
operation."

I thought maybe I had to make my farm provide shared services to
other farms, and add the service account for access to the shared
service provider. But that still didn't work.

Last time i fixed this, i thought all that I had to do was to enable
the web application permissions policy on a particular service
account, and then it would work, It was interesting that I got more
functionality (more public methods worked) out of the url
ssp.byui.edu:port/ssp/admin/_vti_bin/spsearch.asmx than I could out
of ssp.byui.edu:[port]/_vti_bin/spsearch.asmx.

To do this I had to give the user full control over the /ssp/admin
site.

Now I liberally try all the combinations above and I keep getting an
error.

any ideas?

 
Answer #5    Answered By: Rashawn Hopper     Answered On: Mar 05

Further Information:

proc_GetTpWebMetaDataAndListMetaData' procedure attempted to return a
status of NULL

 
Didn't find what you were looking for? Find more on SOAP Errors Or get search suggestion and latest updates.




Tagged: