Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

site collection auditing does not work with a custom site collection

  Asked By: Dontae    Date: Dec 25    Category: Sharepoint    Views: 1668

I've been looking at this for the last 2 days and finally got around to
logging a PSS call with Microsoft this morning.

I thought I might post to the group to see if anyone else has found this
problem.



Here's what I did:-

- create a site collection based on the standard team template

- modify the site, very standard mods, just change/create some document
libraries and set a theme (linchen)

I also tick every box on the site collection auditing settings

- I then save the site as a template and use the stsadm -o addtemplate

(full procedure I use is at
blog.gavin-adams.com/.../creating-site-collection-template
s/ )

- I then create a site collection based on the custom template

When I got to look at the site collection audit logs I get the following
error.

"The specified web does not contain a reporting metadata list."

When I go into the site collection administration, storage space
allocation, click lists I do see a list

Called reporting metadata with 11 items.

I have tried a few variations of ticking or leaving unticked the audit
settings before creating the site template.

I have also tried creating a site template with 'include content'
ticked.

Has anyone else come across this problem?

(or even better come across the problem and solved it!)

Share: 

 

1 Answer Found

 
Answer #1    Answered By: Donte Jefferson     Answered On: Dec 25

Ok for those that are interested, I've had a result from PSS.

Also looks like I wasn't the first to have this problem  just not a
KB,.... yet.

After you create  a site  collection from your custom  site template  you
need to force activate the reporting  feature.

stsadm -o activatefeature -name Reporting -url
http://yourserver/sitecollection/ -force

Hope this helps others that are trying the same thing.

 




Tagged: