Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Single Sign-on / CEWP problem

  Asked By: Bob    Date: Jun 28    Category: Sharepoint    Views: 924

I have a Sharepoint Portal Server 2003 running in test and production
environment. Both the envronments have SPS sp2 and WSS sp2 installed.

The Sharepoint Portal instance in both the servers are IP bound.

I developed a web part for Single Sign-on and deployed it on the test
box after making changes in web.config and wss_mediumtrust.config

Changes in wss_mediumtrust.config file were made based on the
following resource kit chapter. The config changes are talked about
at the end of the article.


The web part work perfectly fine in test environment

When I tried doing the same setup on my production environment,
Single Sign-on works fine but Sharepoint starts having problem with
Content Editor Web Part(CEWP).

Once I put in CEWP on a web page and after making changes to it try
and save, I get this message box

"Cannot retrieve properties at this time"

I remember Sharepoint had this problem when SP was IP bound but based
on Microsoft's information this was taken care of in WSS sp2

When I undo the changes related to SSO, CEWP works fine

As soon as I put in the following code in wss_mediumtrust.config
file, the error starts coming.

<SecurityClass Name="SingleSignonPermission"
Version=, Culture=neutral, PublicKeyToken=
71e9bce111e9429c"/ >

Surprisingly with same set of configurations on my test box SSO works
fine and so does the CEWP.



No Answers Found. Be the First, To Post Answer.

Didn't find what you were looking for? Find more on Single Sign-on / CEWP problem Or get search suggestion and latest updates.