Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Sharepoint search results opening in infopath

  Asked By: Betsy    Date: Nov 16    Category: Sharepoint    Views: 1399

When I search a document library with infopath form files, it will
return the results as xml files. When I try to open it, it asks for
open or save infopath form. I want it to be opened in browser by default.
How to do this?

Share: 

 

4 Answers Found

 
Answer #1    Answered By: Amareswar Karkera     Answered On: Nov 16

Go into your document  library settings and under advance settings just enable
browser documents to be displayed as a web page.

 
Answer #2    Answered By: Cheyenne Jacobson     Answered On: Nov 16

I already had the settings "Display as Web Page"
for the document  library. It is working properly when we go to the
list and open  any existing/new form, by displaying it in browser. But
when I search  for the document in the document library  and click on
any xml  file returned by the search, it is prompting for open or save
the infopath  form. I want the searched form  to be open in browser  when
I click on the search result xml file. Please provide me some solution
for this.

 
Answer #3    Answered By: Makayla Lewis     Answered On: Nov 16

Have you set the "document library" setting to "dispaly in browser". Open
the setting of the document  library and I think it is under advanced
settings.

Perhaps this will address your issue.

 
Answer #4    Answered By: Emmanuel BL     Answered On: Jun 07

here is the answer, it works really fine for me: phillyxaml.org/blog/Lists/Posts/Post.aspx?ID=41

the subject is modify the XSLT Applied to the Search Results

 
Didn't find what you were looking for? Find more on Sharepoint search results opening in infopath Or get search suggestion and latest updates.




Tagged: