MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Sharepoint Problem With .NET Framework

  Asked By: Harshita    Date: Feb 18    Category: MOSS    Views: 1030

One of our system admins has decided to install a software on sharepoint 2007
The software required .NET Framework 1.1 which was not previously installed.
He has installed the .NET Framework 1.1 and IIS start not working.
Then he has reinstalled framework v2.0577 and seen that IIS is working but MOSS
2007 isn't.
Then he called me. (What a suprise!).
We were getting 403 access denied error for all web apps including central
I have rerun the config wizard of the sharepoint.
Now I get central admin working but still getting access denied for other web

I have discovered that if I use http://<servername> I get error but If I write
I get the page with missing custom css (we are using main.css file to override
default styles)
So I decided to add "default.aspx" to Web application settings namely documents.
Still no success.
Then I check for windows update and seen taht sp1 for .net v2.0 and 3.0 sp1 is
published and installed them.
No luck.
Still can not access http://<servername>
I need an urgent help.
What should I do



5 Answers Found

Answer #1    Answered By: Tanner Moss     Answered On: Feb 18

What version of the .NET Framework is the MOSS IIS website configured to

Answer #2    Answered By: Bobby Boyd     Answered On: Feb 18


is configured also it is the only available one.

Answer #3    Answered By: Sean Perez     Answered On: Feb 18

Sounds like the IIS website got messed up. There may be a shorter
approach, but I'd be tempted to just remove and recreate the Web
Application. Just make sure you keep your content databases.

Answer #4    Answered By: Moises Harrington     Answered On: Feb 18

I had exactly this situation although, rather embarassingly, it was
of my own making. Anyhow, if you are running on a 64 bit server then
take a look at this KB article: http://support.microsoft.com/kb/894435

If indeed you are in the same situation as I got myself into it
should just be a case of switching back to the 64 bit version of .NET
2.0 and everything will be magically restored!

Answer #5    Answered By: Kory Brock     Answered On: Feb 18

I have deleted the web applications (be careful not to
delete the content databases) and

re-created them and now it works.

Didn't find what you were looking for? Find more on Sharepoint Problem With .NET Framework Or get search suggestion and latest updates.