Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

SharePoint failure

  Asked By: Payal    Date: Aug 26    Category: Sharepoint    Views: 808

My SharePoint (version 1) installation failed this morning. I can no longer
see document folders or files from the Web folders, the Document Library
dashboard shows error messages in all the Web parts (Script Execution Error:
Microsoft JScript runtime error 'strRootDocLibLabel' is undefined line = 1,
col = 0 (line is offset from the start of the script block). Error returned
from property or method call.), and when I attempt to search for a file I
get a 403 Forbidden message from IIS. Also, the Categories dashboard is
empty, and subscription notifications are empty even though I should have a
bunch of notifications waiting for me. In the Management dashboard, when I
go to WorkPlace Settings, Content Sources, I get another error message (The
folder cannot be found on the server. The folder may have been deleted or

I'm not sure what's going on, but it might be related to a change made on
the workspace via IIS console. One of our network guys was looking at the
security settings, and he may have changed something there using the IIS
permissions wizard.

Also, I was attempting to create a new workspace this morning on the same
server and the process failed. The fail message indicated I should look at
the event log for more details, but nothing has turned up there.



5 Answers Found

Answer #1    Answered By: Cassandra Cooper     Answered On: Aug 26

Try removing Allow Anonymous Settings in IIS Security Tab...

Answer #2    Answered By: Elaina Suarez     Answered On: Aug 26

And don't allow anyone to play with your SPS machine! Too many people do
not understand SPS and make changes that affect the server unknowningly.

Answer #3    Answered By: Kacey Russo     Answered On: Aug 26

Removing the Allow
Anonymous had the salutary effect of bringing the site back up for the most
part. At the moment, the only thing not working still is the Search
functionality. I can get to the search  page, but when I click on the Go
button, I get a 403 Forbidden error.

Darrin - I'll have to work on and through your suggestion. It's the right
way to go, but since I'm the Technical Writer in the group . . . .

Any ideas about the 403 error  on search?

Answer #4    Answered By: Rebecca Lewis     Answered On: Aug 26

I am not sure but it should be the problems with permissions.
Can you check out the permissions on the resources folder.
Is parent's settings applied on the folder or custom settigns are there.

Answer #5    Answered By: Emily Clark     Answered On: Aug 26

That's right. I went into IIS and pulled up the Properties page for the
workspace and discovered that only the Read check box was checked. That
means that when I tried to do a search  (and tried to create a new
sub-folder) those settings were telling the system not to allow that: no
writing! So when I checked the Write box as well, and restarted SharePoint,
the system went back to normal.

Bottom line  is I'm going to have to watch these settings more closely in the
future to make sure no one changes them.

Didn't find what you were looking for? Find more on SharePoint failure Or get search suggestion and latest updates.