Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Sharepoint Error

  Asked By: Tapasvi    Date: Oct 19    Category: Sharepoint    Views: 569

We need your help if anyone here had encountered this problem before.
A bit of history, we installed 2.0 Framework to our servers running
IIS 6.0. We assigned some of our .net web apps 2.0 Framework and
grouped them in a separate pool. Now when our users browse to our
sharepoint portals, they get this RANDOM error message...

"This Windows SharePoint Services virtual server has not been
configured for use with ASP.NET 2.0.50727.42. For more information,
please refer to Knowledge Base article 894903 at
http://go.microsoft.com/fwlink/?LinkId=42660."

We cannot apply the KB article since our portals are still running 1.1
framework.

Right now, the temporary remedy is to reset IIS. We spoke to the MS
tech support, they are as lost as we are. They are still investigating
our problem. Anyone here can offer us some advice or solutions.

Share: 

 

4 Answers Found

 
Answer #1    Answered By: Naimish Ranganekar     Answered On: Oct 19

In IIS Manager under Web Service Extensions, does ASP.NET v2.0.50727
show status 'Allowed'?

 
Answer #2    Answered By: Caleb Gordon     Answered On: Oct 19

Let me clarify the behavior. You have recently installed  .NET 2.0
and provisioned some sites to use .net 2.0 that are 100% non-
sharepoint to use .net 2.0. Then you still have your legacy 1.1
sharepoint 2003 app running as a website that is set to use 1.1.
Further you have ensure that no 2.0 websites are using the same
application pool  as your 1.1 websites.

IF all of the above is true you can try to add an entry in the
web.config of your .net 1.1 web  applications within IIS that forces
the web app to startup in 1.1. You migh want to take a look at the
following. However it may prevent 2.0 from running on your server
so you will need to test it out. It is easey to revert. The other
things is I think you can add everything in the <startup></startup>
blob into the configuration arrea of your web.config file for
each .net 1.1 app. I have seen the is behavior before and we ended
up unistallaing 2.0 from the server  as it was not needed on that
server to fix the issue quickly.

Beyond that you might want to remove sharepoint  from the virtual
server within central admin and then re-extend it (BE SURE YOU DON"T
CHOOSE THE DELETE CONTENT DATABASE OPTION WHEN YOU DO THIS!!!!!!).
IF you have more problems still I will look furhter into your issue.

www.kbalertz.com/.../...e.visit.SharePoint.Portal.
Server.Windows.SharePoint.Services.virtual.server.configured.aspx

 
Answer #3    Answered By: Christie Carlson     Answered On: Oct 19

I assume this is for a standalone ASP.NET 2.0 app. If
so, do the following:

-Get into IIS.

-Right click on the virtual  server of your standalone
app and select properties.

-Click on the ASP.NET tab. On the ASP.NET version,
select 2.0 (it probably says 1.1).

This should work, but you may have to restart IIS
after making this change.

 
Answer #4    Answered By: Dorothy Farmer     Answered On: Oct 19

This sounds eerily familiar. We just wrapped up a case with
Microsoft regarding an issue similar to this. We were finally given
a hotfix for this, which can be located at
support.microsoft.com/default.aspx

For the details on our specific situation, you can read my blog post
about it at http://www.jasonbrinkle.com/2006/12/11/my-first-
sharepoint-support-case-with-microsoft/.

 
Didn't find what you were looking for? Find more on Sharepoint Error Or get search suggestion and latest updates.




Tagged: