Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Sharepoint authentication question.

  Asked By: Grace    Date: Mar 29    Category: Sharepoint    Views: 802

Default install with sharepoint you are always prompted to input your
username and password. This is fine when have to access external to
the enviroment.

Since I log on to the domain inside the company and am on the local
network with the server hosting sharepoint is there anyway to prevent
the login screen when going to companyweb but still keeping the
permissions per the site?

I would think that it would already use the authentication that was
used when you actually log on to the domain. Why does it make you
retype your user and pass again when you have already authenticated
against the server?

I guess what i want to do is prevent the logon screen internal to the
organization while still keeping the permissions assessed to the users.



6 Answers Found

Answer #1    Answered By: Karla Morrison     Answered On: Mar 29

Its because you are accessing it with a fully qualified domain  name - i.e.
intranet.mycompany.com and so internet explorer thinks the site is on the
internet even though the site uses your internal  domain name !

To fix it you just need to add the sites address to either the local intranet or
the trusted sites zone in internet explorer. Myself, I prefer the trusted sites
zone. Alternatively, you can just access  the site by host name and leave off the
domain name and that will work just as well.

You can read all about it here http://support.microsoft.com/kb/303650.

Answer #2    Answered By: Patricia Richardson     Answered On: Mar 29

That happens when i access  it externally which is fine. THis is
internally when i go to http://companyweb. That is what we use
internally and are still prompted  for user  name and pass.

Answer #3    Answered By: Damon Garner     Answered On: Mar 29

You will need to add both versions of the name to a zone that is configured to pass  through the local credentials. By default, that would be the local intranet zone.

Answer #4    Answered By: Christop Mcfadden     Answered On: Mar 29

There is a security setting for the Intranet or the Trusted Sites Zones in Internet Explorer that will automatically pass  your domain  logon credentials to the Web Server.  It is the last setting in the Custom Security Panel in each Zone.  It is set that way by default  for the Intranet Zone, but you need to change it to have it apply in the Trusted Sites Zone.  After you have set the custom security setting on the Zone simply add the URL for the Portal to the Zone.  Then when you are logged on to the domain your credentials will be passed and you will not be prompted.  If you not logged in to the Domain your credentials will be passed in the background, they will fail, and you will then be prompted. Since you are still Authenticating with your Domain credentials you will still have the same permissions.

BTW, if you need to make this setting for a whole network it can be pushed out through a Group Policy object.

Answer #5    Answered By: Stefanie Ruiz     Answered On: Mar 29

yes that was my next question. Do you have a doc that shows you how to
push that setting out via GPO?

Answer #6    Answered By: Damon Garner     Answered On: Mar 29

I believe that the IE SDK has extra ADM files that will extend your IE group policy settings.

Keep in mind that if you change the Trusted zone to pass  current logon  credentials, then when you go to Trusted sites on the Internet, your browser will first pass your credentials over the Internet for authentication  to the site.

Didn't find what you were looking for? Find more on Sharepoint authentication question. Or get search suggestion and latest updates.