Logo 
Search:

MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Using Sharepoint 2007 with Office 2007

  Asked By: Aaditya    Date: Mar 31    Category: MOSS    Views: 984

Whenever I try to create an Excel Web Access Web Part or whenever I
select "View in Browser" for any of my Excel documents I get the
following error:

Access denied. You do not have permission to perform this action or
access this resource

I have added the document location as a trusted location and I've
assigned myself as a Site Collection Administrator, but I still cannot
view the document.

What am I missing?

Share: 

 

2 Answers Found

 
Answer #1    Answered By: Jack Carroll     Answered On: Mar 31

I dont think IIS Reset can help here, this will just recycle the app-pool.

Follow these steps and check if that helps:

1. Start | Programs | Microsoft Office Server | Sharepoint Central Administration
2. Click Application Management
3. Click Create or Configure this Farms Shared Services
4. Click the name of the Shared Services Provider
5. Click Edit Excel Services Settings
6. Look at the settings for File Access Method. There are two choices, Impersonation and Process Account. Whatever it is set to here, you could change the setting to the other and see if that fixes the issue.
7. (If this is a Standalone installation, you may need to run this command to have the change executed in a timely manner: stsadm –o execadmsvcjobs. You would run this from the c:\Program Files\Common Files\Microsoft Shared\web server extensions\12\bin folder.)

The File Access Method setting determines the authentication method used by ECS to get workbooks from trusted file locations other than Sharepoint Document Libraries. Impersonation is the default. If set to impersonation, the end-user account is used to access the workbooks. If set to Process Account, the ECS process will be used to access the workbooks.

 
Answer #2    Answered By: Chandrabhan Agarkar     Answered On: Mar 31

Also check one more thing (if the previous steps dont help you):

What is the authentication setting in the published work book for the connection (Data -> connections ->)? Try setting this to “no authentication”.

Also check the setting for EXTERNAL DATA (on the same Excel Services Settings page as I mentioned in the earlier reply, this is the last section on that page) Check the account specified for Unattended Service Account.

Basically: "The credentials for a default Windows account that Excel Calculation Services uses for connecting to data sources that require user name and password strings for authentication. If this account is not set, connections to these data sources fail."

 
Didn't find what you were looking for? Find more on Using Sharepoint 2007 with Office 2007 Or get search suggestion and latest updates.




Tagged: