MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Server time doesn't match upload timestamp

  Asked By: Jasen    Date: May 05    Category: MOSS    Views: 1559

I have a MOSS2007 SP1 box that was recently built, and for some reason it
was set to Pacific time. We're on Central here, so I logged on as an
administrator and changed the time zone so the clock was running correctly
(right time zone, right time).

At that point I thought the problem would have been solved, but apparently
when anyone add/updates/etc, the corresponding timestamp is two hours
earlier than the actual change. Google hasn't turned up anything relevant,
but maybe I'm just not feeding it the right words. Has anyone encountered
this before?



6 Answers Found

Answer #1    Answered By: Destiny Lewis     Answered On: May 05

On the main page of your site collection, SITE ACTIONS > SITE SETTINGS > SITE
Change the time  zone there and check the box  at the bottom for all sites inherit
these options.

Answer #2    Answered By: Tanisha Rowe     Answered On: May 05

Check to see if the Time Zone settings have been set  on the Web application

Answer #3    Answered By: Sierra Lewis     Answered On: May 05

No default at the web application level, though that's good to know (I was
looking in Operations since I didn't think that sort of thing would be
assigned per application). Looks like I'll be doing some extensive
reassigning by hand.

Funny how you can work with SharePoint for years and still miss something
like this.

Answer #4    Answered By: Dwight Becker     Answered On: May 05

First, after changing the timezone on the server  did you re-boot? I think
SharePoint picks this up from the server default at startup.

If that still doesn't work you don't need to assign a custom timezone for every
site collection. Until you assign a timezone at the Site Collection level it
will automatically use the default set  at the Web Application level. After
setting it in the Site Collection that will take precedence. You want to set it
at the Web App level, not the site collection level to fix your problem. Both
will work, but one is clearly a lot more effort.

Remember individual users can also set the time  zone for themselves which will
take precedence over all the other settings. If users have adjusted the
timezone setting for themselves changing the site collection or web app setting
won't help.

Answer #5    Answered By: Amar Kumbar     Answered On: May 05

I'm not worried about individual users; they're all in one
location and none of them know enough to go looking for time  zone
information. I'll keep the reboot in mind, though I'm surprised that
SharePoint wouldn't just key off the system settings (must be a performance

Answer #6    Answered By: Marc Dixon     Answered On: May 05

when I set  it at the web app and Site Collection level, new sites were
still being created on Pacific time. Methinks this is a particularly deep
rabbit hole.

Didn't find what you were looking for? Find more on Server time doesn't match upload timestamp Or get search suggestion and latest updates.