Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

"Server error: You need a more recent version of SharePoint Designe

  Asked By: Johanna    Date: Apr 14    Category: Sharepoint    Views: 2808

I have a new WSS 3.0 installation on a Win2003 R2 server. The server also
has SPD 2007 installed on it. SPD is the version available on the MSDN
Subscription site.

I've run Microsoft Update and applied all of the required and optional

The server farm version is The SPD version is 12.0.4518.1014
MSO 12.0.6017.5000.

I can open the top-level site in SPD with no problem. However, when I try
to open the subsite in the top-level site, I'm getting the following SPD
error message:

Server error: The version of Windows SharePoint Services running on the
server is more recent than the version of SharePoint Designer you are using.
You need a more recent version of SharePoint Designer.

It doesn't seem to matter if SPD is run locally on the server or remotely.
The result is the same error message.


1. What is causing this problem with SPD?



3 Answers Found

Answer #1    Answered By: Harshita Padwal     Answered On: Apr 14

just like you I have the latest version  of SD on couple of
different computers and I have seen this error  on several occassions myself
under different circumstances, for example -

I am yet to find a solution to this. If you do, please post the answer.

Answer #2    Answered By: Jennifer Jones     Answered On: Apr 14

The following isn't conclusive but I believe Microsoft Update is applying
WSS 3.0 hot fix KB932091 which is kicking up the WSS 3.0 build or version

I had to completely rebuild my WSS 3.0 server  this morning.

Answer #3    Answered By: Annie Norris     Answered On: Apr 14

It's not a problem with WSS 3.0 hot fix KB932091.