Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Server Error in '/_vti_bin' Application

  Asked By: Marissa    Date: May 04    Category: Sharepoint    Views: 2065

After developing a SharePoint web service and
deploying in a server, when trying to see it:
https://myServer/_vti_bin/myWebService.asmx, an error
page shows up instead:

Server Error in '/_vti_bin' Application
Runtime Error

Browsing the SharePoint standard alerts.asmx gives me
the same error.

Then I tested it on another server. This time, both
alerts.asmx and myWebService.asmx are fine.

What could have been wrong?

Is there a procedure that I can check what have gone
wrong on my first SharePoint server?

Share: 

 

4 Answers Found

 
Answer #1    Answered By: Titus Sweet     Answered On: May 04

sounds like a permission error. make sure your sharepoint  admin account is admin on the IIS box and SQL box. also, reinstall IIS if you modified the default permissons in IIS. Hope this helps.

 
Answer #2    Answered By: Laura Walker     Answered On: May 04

I checked the permissions and didn't find anything
suspecious. It worked before. I will do a further
check.

Is there anything else besides permission that will
cause this kind of problem?

 
Answer #3    Answered By: Christop Mcfadden     Answered On: May 04

Did you change the web.config filein the \_layout\_vti_bin folder?
when you say you deployed your web  services did you deploy to the same directory as other standards asmx? try to deploy on another virtual server  or another virtual directory?

 
Answer #4    Answered By: Victoria Bell     Answered On: May 04

I deploy my web  service this way:
1. copy the asmx, wsdl.aspx, disco.aspx files to
60\ISAPI
2. register the asmx  in 60\ISAPI\SPDisco.aspx
3. copy the web service  DLL to 60\ISAPI\BIN

This has always worked.

I didn't change web.config file in _vti_bin folder?
BTW, what and where exactly the folder is?

All SharePoint Portal native web services definitions
are in the same 60/ISAPI directory.

I don't think the problem is specifically with my own
web service. Because when I try
http://myServer/_vti_bin/alerts.asmx, it gives me the
same error.

Alerts.asmx web service comes with the SharePoint
portal. The above works in all other servers I have
access to.

Anything else I should check?

 
Didn't find what you were looking for? Find more on Server Error in '/_vti_bin' Application Or get search suggestion and latest updates.




Tagged: