Sharepoint 2010 Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint 2010       RSS Feeds

"Security Token Service is not available" issue when deploing custom claims provider

  Asked By: Pablo    Date: Jun 03    Category: Sharepoint 2010    Views: 12734

I'm having issues after deploying our custom claims provider (ClaimsProvider.wsp) to a Sharepoint Farm.
(I also include the command line run on the Sharepoint 2010 Management Shell).

We add the solution the ISG Claims provider
Add-SPSolution -LiteralPath “C:\claimsprov\ClaimsProvider.wsp”

And then we try to install/deploy it.
Install-SPSolution -Identity ClaimsProvider.wsp –GacDeployment

Then, the SecurityTokenServiceApplication can not resolve the Active Directory users claims.

The problem appears when we deploy our package:

If we run the Sharepoint Health Analyzer after deploying our provider, we get the following message:
The Security Token Service is not available. ISGSITES2A SPSecurityTokenService (SecurityTokenService)

If we retract (unistall) our solution
Disable-SPFeature -Identity ClaimsProvider_Feature1 -Url http://SharepointSite:1111
Uninstall-SPSolution -Identity ClaimsProvider.wsp

And re run the Sharepoint Health Analyzer, We can check that the error is gone, and the Active directory recognition gets back to work.

Any clue or help about this?...





1 Answer Found

Answer #1    Answered By: Kartik Anand     Answered On: Jun 03

There are a few things that you can do to verify.

- Make sure there is no bug in your code. Did this work on your local box?
- Are you overwritting the default claims provider? I don't think that is a good idea. I would think you have to create a login provider and then associate your custom claims provider to that Login provider.