Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Security Issue....

  Asked By: Jackson    Date: Jan 23    Category: Sharepoint    Views: 622

Most of you at this stage will have either experienced or heard of the
following problem.
When I assign security on my workspace I have to restart the services or
re-boot before these security changes are applied.
I have this problem on two servers - one of which is newly installed with
SP1 and only contains one standard workspace!

Anyway, I have been messing around trying a few different things and I have
come across the following scenario - which is STRANGE!

- I gave user testuser access to the workspace.
- Without restarting services, I logged in as testuser and they cannot
access the workspace
- Logged in as the admin I restarted the IIS Admin, MS Exchange Info Store,
SPS, SMTP and WWW Publishing services
- I logged in as testuser and I can access the workspace
- Logged in as the admin I removed the users access
- Without restarting the services I logged in as testuser and I cannot
access the workspace

Conclusion: Granting permissions did not work as it should, removing
permissions worked!!

So I tried the following....

- I granted the Everyone group access to the workspace and restarted the
- I removed the Everyone group and testuser2 (a new user) cannot access the
- I granted access to testuser2 w/o service restart...
- I then logged in as testuser2 and was able to access the workspace!!!

So, basically I granted Everyone access, restarted services, removed
Everyone and now security assignments works correctly w/o service restarting

I don't know what's going on!!! Can someone else who has the same security
problems as me try this scenario.....
Does this make sense to anyone because it certainly doesn't to me!?



7 Answers Found

Answer #1    Answered By: Hiral Daftary     Answered On: Jan 23

No, I have it also..................

Answer #2    Answered By: Rosalie Buckner     Answered On: Jan 23

We certainly are not the only two experiencing it as I have come across
numerous queries in different newsgroups on the same issue  but still no sign
of a solution!

I am aware of the NT group workaround but my problem  is due to the
complexity of the security  required within my workspaces I would end up
creating a load of NT groups....

There HAS to be some solution, my next step will be to go to microsoft but
go live dates are looming and this will be a big problem!!!

Anyway, any other input is welcome and if anyone has tried the scenario
below and finds a similar outcome let me know.

Answer #3    Answered By: Carrie Ross     Answered On: Jan 23

I have the same problem. The solution for me currently is creating local NT
groups and them adding them to the permissions of the Workspaces.

Answer #4    Answered By: Lisa Hill     Answered On: Jan 23

Even I had the same problem. I use local groups to apply security  on one of
my workspace.
Whenever I ada a new user to a local group, permission doesn't take effect
unless I restart
All the services. In some cases I need to reboot the server for the
permission to take effect.
But again this is not consistent. Sometimes it works without rebooting or
restarting the services.

But I have had no problem  whey applying security based on individual user.

Answer #5    Answered By: Bret Warner     Answered On: Jan 23

Sometimes I have to reboot when I add a domain user to a local Machine

Answer #6    Answered By: David Small     Answered On: Jan 23

We also have this problem. I was very surprised when we got caught
with this issue. We have posted this problem  to Microsoft.

Didn't find what you were looking for? Find more on Security Issue.... Or get search suggestion and latest updates.