Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Security Information Pop-up From People and Groups - My Site Related

  Asked By: Gonzalo    Date: Mar 08    Category: Sharepoint    Views: 1815

An interesting issue here and I'm having trouble trying to
resolve it, so hopefully the folks here can give me a hand. Let's set
the stage...

I've created 1 SSP to hold 3 Web Apps (SSP Web Admin, My Site and
Portal) and each Web App was created on port 80. The URLs for these 3
are only accessible internally.

I then extended the My Site and Portal Web Apps so that I could set up
SSL for external access. So far so good.

I then went into My Profile via the external address, valued some
details, uploaded a picture, saved it, and all looks good.

And now, the issue...when I go to the Portal via the external (read:
SSL) URL and go into the People and Groups area of the Site, I get that
pesky "Security Information" dialog box. You know the one: "This page
contains both secure and nonsecure items. Do you want to display the
nonsecure items?".

What I've seen is that when I mouse-over my picture, the URL to my
profile shows up as the external address (as I came into the Portal via
its external address), however, if I right-click the picture and select
Properties from the context menu, the Address property in the General
tab shows the internal (read: non-SSL) URL to the picture.

Now I understand that this is why I get the dialog box/prompt (I'm
trying to view an http item over an https connection), but, did I do
something wrong/miss something? Why is the People and Groups list
showing the external links but using the internal ones as the picture

I think I explained this right. Any help in resolving this would be
greatly appreciated.



1 Answer Found

Answer #1    Answered By: Ella Sargent     Answered On: Mar 08

If you go into your Shared Services Administration website and then
click the My site  settings link under the User Profiles and My Sites
section the My Site Settings page appears. Note the Preferred Search
Center URL and the Personal Site Provider URL. The values for these
fields are the Default Zone URLs. I tried changing these to one of the
other zone's URLs (based on my Alternate access  Mappings) and the
changes don't take. You can actually enter the different URL and hit
the <OK> button and it sends you back to the SSP website like all's ok,
but if you reenter the My Site Settings page you'll see the Default Zone
URL still there.

Why is this an issue? Well, if you have a Site that's accessible  via
http as its Default Zone, and then create another AAM entry that points
to https, you'll get challenged w/the security  information pop-up
because you're running from http-to-https. In my experience, the
challenge comes up when viewing the individual's information  in the
People and Groups list.

To resolve the challenge, in my case, I'm just making https  the required
access method, thereby bypassing the above issue. However, in places
where http  access is desired (inside the network) and https (for
outside) you'll get the challenge.

I've tested this a bunch of times and I can duplicate this, so if anyone
else can identify a way to have access to a site both http and https and
not get that pop-up, I'd love to see.