MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Search an SSL enabled MOSS farm

  Asked By: Bhavani    Date: Aug 30    Category: MOSS    Views: 1586

I am having a problem with people search after SSL enabling my MOSS
farm. My documents, lists and items all crawl and index with no
errors and return the appropriate URL (https://moss.mycompany.com).
However, my "People" scope remains as showing 0 Items and I am seeing
access denied errors in the gatherer logs for sps3://servername.

I have taken the following steps to get to this point:

1. Configured my existing web application, named SharePoint and
using port 80, to use SSL, require 128 bit encryption and use Windows
Integrated Authentication.
2. Created and extended a new web application
named "SharePointExtended" and configured it to use port 8088.
3. Assigned static IP addresses to SharePoint and
4. Locked SharePointExtended down so that it is only accessible
from SharePoint and my SQL server.
5. Created an Alternate Access Mapping that points
http://servername to https://moss.mycompanyname.com (all portal URLs
successfully resolve to https://moss.mycompanyname.com now).
6. Configured my content source to use the following as start
https://moss.mycompnayname.com (replaced http://servername in
content source config)
sps3://servername (already existing in content source config)
7. Created a Server Name Mapping that maps https://servername to
https://moss.mycompanyname.com (I tried http://servename:8088 but it
wouldn't show the results as coming from
https://moss.mycompanyname.com they showed as coming from
8. Reset all crawled content.
9. Started a new crawl and got the following error and while
documents index and are searchable people are not.

Access is denied. Check that the Default Content Access Account has
access to this content, or add a crawl rule to crawl this content.

I have verified that my default content access account does
have "Full Read" access to all content sources.

Suggestions, ideas or thoughts?



4 Answers Found

Answer #1    Answered By: Gina Freeman     Answered On: Aug 30

Try changing sps3:// to sps3s:// in your search  profile. I seem to
remember having problems with this when I was troubleshooting our
people search functionality.

Answer #2    Answered By: Tyrell Nash     Answered On: Aug 30

I had seen that online somewhere and had tried it but
unfortunately it did not work.

Answer #3    Answered By: Silvia Wilkinson     Answered On: Aug 30

Only other thing I can think of is to make sure that the account
you're using for search  has the proper access permissions to crawl  AD
information. If that service account doesn't have the right
permissions, you'll get errors. I can't remember off the top of my
head what permissions need to be granted to your service account for
that, however - someone else will have to remind both of us.

I'm assuming it was working before, which makes me think that you
might have set some security settings that are prohibiting the service
account from properly accessing the data.

Answer #4    Answered By: Candy Walter     Answered On: Aug 30

I had thought of that and verified that my search
account (AppsMOSSSearch) has "Full Read" permissions under
the "Policy for web  Applications".

I am wondering if it is tied to how I set up my "My Site" web
application. In order to make the my site link look like it is coming
from my main SharePoint site I followed the directions at Chris
Johnson's blog at the following link:


I hate to restart and do it differently but would really like to have
the people search  working correctly. I think that would be a huige
benefit for my company.

Didn't find what you were looking for? Find more on Search an SSL enabled MOSS farm Or get search suggestion and latest updates.