Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Search for people not working fixed!

  Asked By: Felicia    Date: Jul 14    Category: Sharepoint    Views: 893

I managed to get this working. The problem was revealed by a bunch of
errors in the event viewer and some time with Google. I found the
following web page:
earing-hosts-file.aspx which sets out what is wrong and how to fix it.
Essentially SharePoint has to be able to delete and create
C:\Windows\system32\drivers\etc\HOSTS when it is crawling SharePoint
sites in some circumstances. When it can't do this the crawl fails. It
was said in some article I found that this was fixed in the RTM version
but that is what I am running and it doesn't appear to be fixed.
However, the solution (while not ideal perhaps) is easy to implement and
works. It seems there is an error in the article though. Near the end he
lists the permissions that must be granted to the WSS_ADMIN_WPG group on
the ...drivers\etc directory. He doesn't include "Delete Files and Sub
Folders". I found that was required as SharePoint actually tries to
delete the HOSTS file.

Anyway, having done as he suggests with that addition I mentioned and
then setting a full crawl going I found I could search for people once
the crawl had finished. Yippee.... Anyway, I thought I would post this
in case someone else had the same problem although I don't think I have
seen anyone mentioning it before.



1 Answer Found

Answer #1    Answered By: Darrius Whitfield     Answered On: Jul 14

SharePoint generally only messes with the hosts file when you have
checked the box to "use a dedicated WFE" for searching.

See my blog at

Was that your scenario?

Didn't find what you were looking for? Find more on Search for people not working fixed! Or get search suggestion and latest updates.