Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Search options

  Asked By: Rico    Date: Nov 08    Category: Sharepoint    Views: 621

We are trying to incorporate SPS Site Search into our
WSS Sites based on the following article from
MSDN:
<msdn.microsoft.com/.../\
html/ODC_SPSSearchBoxwithPortalSearchResults.asp>.

The issue with this solution is that users are
redirected out of their existing WSS sites and onto
the search page of the SPS site when executing this
search solution.
This is a navigation usability issue as users will
have a difficult time understanding how to get back to
their original WSS site location.
Our quick workaround solution is to implement a
modified version of the search.aspx page on the SPS
site definition.
This modified version of the search.aspx is called
"WSSsearch.aspx" and will be executed as a new pop-up
window.
Our customization is to remove the header navigation
section as this will allow us to leverage the current
built-in search functionalities and minimize user's
navigation options beside performing a search.
We are also doing our Home page customization directly
on the SPS site definition as this site is not
possible to re-provision as other sites.
Our SPS site remain ghosted and set not to be modified
by Frontpage.
Our issue is trying to add this new aspx page to the
SPS site definition.
We are aware that we cannot add new pages to existing
sites but wonder whether there is a way to bypass this
limitation such as adding a record in the database?
This is what we have done so far:
· Modified the ONET.XML file at C:\Program
Files\Common Files\Microsoft Shared\web server
extensions\60\TEMPLATE\1033\SPS\XML and added the
following to the "Default" Module:

<File Url="WSSsearch.aspx" Type="Ghostable">
<AllUsersWebPart WebPartZoneID="MiddleLeftZone"
WebPartOrder="1"><![CDATA[<WebPart
xmlns="<http://schemas.microsoft.com/WebPart/v2>" target="_blank" rel="nofollow">http://schemas.microsoft.com/WebPart/v2>">
<Assembly>Microsoft.SharePoint.Portal,
Version=11.0.0.0, Culture=neutral,
PublicKeyToken=71e9bce111e9429c</Assembly>
<TypeName>Microsoft.SharePoint.Portal.WebControls.AdvancedSearchControl</TypeNam\
e>
<Title>Advanced Search</Title>
<Description>Advanced Search Control</Description>
<PartOrder>1</PartOrder>
<FrameType>None</FrameType>
<AllowMinimize>true</AllowMinimize>
<AllowRemove>true</AllowRemove>
<IsVisible>true</IsVisible>
</WebPart>]]></AllUsersWebPart>
<AllUsersWebPart WebPartZoneID="MiddleLeftZone"
WebPartOrder="2"><![CDATA[<WebPart
xmlns="<http://schemas.microsoft.com/WebPart/v2>" target="_blank" rel="nofollow">http://schemas.microsoft.com/WebPart/v2>">
<Assembly>Microsoft.SharePoint.Portal,
Version=11.0.0.0, Culture=neutral,
PublicKeyToken=71e9bce111e9429c</Assembly>
<TypeName>Microsoft.SharePoint.Portal.WebControls.SearchResults</TypeName>
<Title>Search Results</Title>
<Description>Sharepoint Portal Search
Results</Description>
<PartOrder>2</PartOrder>
<FrameType>None</FrameType>
<AllowMinimize>true</AllowMinimize>
<AllowRemove>true</AllowRemove>
<IsVisible>true</IsVisible>
<ResultListID
xmlns="urn:schemas-microsoft-com:sharepoint:DataResultBase">sch</ResultListID>
</WebPart>]]></AllUsersWebPart>
</File>
· Restart IIS.
Any workaround suggestions or feedback will be greatly
appreciated. Also, please feel free to contact me to
discuss this further.

Share: 

 

No Answers Found. Be the First, To Post Answer.

 
Didn't find what you were looking for? Find more on Search options Or get search suggestion and latest updates.




Tagged: