Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Search Excludes PDF Documents

  Asked By: Mackenzie    Date: Mar 22    Category: Sharepoint    Views: 1457

I am noticing that SharePoint search results are excluding PDF files that are in some of my document libraries. If I search for the word Enrollment, and I have a PDF document titled United Healthcare Enrollment Form, shouldn’t the search automatically pick up that document?

If not, how do I configure the search to include it?

Share: 

 

8 Answers Found

 
Answer #1    Answered By: Matt Prince     Answered On: Mar 22

Have you installed the ifilter for Adobe? You have to specifically configure  SharePoint for Adobe files. This link should help.

wss.collutions.com/Lists/FAQ/DispForm.aspx?ID=126

 
Answer #2    Answered By: Brooks Bond     Answered On: Mar 22

I followed all of the steps outlined in the attached link. Still did not  work. I used the iFilter for ftp://ftp.adobe.com/pub/adobe/acrobat/win/all/ifilter60.exe.

I also ran the SQL Server stored procedure recommended in the article. Not only are existing PDF files  not showing up in search  results, but neither are new ones that I have tried adding after the fact.

 
Answer #3    Answered By: Gregg Wilkinson     Answered On: Mar 22

Are you trying to make this work on WSS sites or a Portal? They have different setups as they use different search  technologies.

 
Answer #4    Answered By: Darrel Sexton     Answered On: Mar 22

It was this step that I was missing:

Then navigate to Site Settings > Configure search  and
Indexing > Include File Types (in the General Content Settings and
Indexing Status section).

Even though the original instructions said to do it, I somehow overlooked that part.

PDF searching and inclusion in search results  is working now as it should.

 
Answer #5    Answered By: Tory Sellers     Answered On: Mar 22

If you want the pdf  files to show with the correct icon, here
are the steps to follow:

First, find the pdf16.gif icon (look in Google Images if you
don't). Then navigate to Site Settings > Configure Search and
Indexing > Include File Types (in the General Content Settings and
Indexing Status section).

Add the pdf extension, and then copy that image to the \Program
Files\Common Files\Microsoft Shared\web server extensions\60
\TEMPLATE\IMAGES directory.
Next, edit the \Program Files\Common Files\Microsoft Shared\web
server extensions\60\TEMPLATE\XML\DOCICON.XML file and add this
entry in the
<ByExtension> setting with the others:

<Mapping Key="pdf" Value="pdf16.gif" />

Then you should be good to go! You might have to reboot the server.

 
Answer #6    Answered By: Agustin Miranda     Answered On: Mar 22

To included the icon, all you have to do is issue an IISRESET command after. No
need to
reboot the server. This is documented in Microsoft's Q article 837849.

Adding PDF's is a task on my ToDo list, but I haven't done it so far. I've hear
that iFilter 6.0
is the way to go and the readme directs you thru the install. I would assume
you'd have to
initiate an index crawl before the PDF's actually show up in the results.

 
Answer #7    Answered By: Arron Middleton     Answered On: Mar 22

Does iFilter have to be installed on the Search Servers as well as the
Index server in a medium farm?

 
Answer #8    Answered By: Vance Hardin     Answered On: Mar 22

The iFilter has to be installed on the database server when using WSS search, as it uses SQL Server's full-text indexing as an engine. The iFilter has to be installed on the Index server(s) on a Portal farm as they are the servers processing the documents.. Once they are in the indexes they are treated just like any other file that has been indexed, so your search  servers should not  need the iFilter.

 
Didn't find what you were looking for? Find more on Search Excludes PDF Documents Or get search suggestion and latest updates.




Tagged: