Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Search is Broken

  Asked By: Ezequiel    Date: Oct 03    Category: Sharepoint    Views: 1121

We have a pretty vanilla implementation of SPS. Search used to work
fine, but now it does not.

When we go to <<Portal>>|Site Settings|Configure Search and
Indexing, we are getting the following error:

Failed to initialize content sources.
System.UnauthorizedAccessException: Access is denied.
at mssctlbm.SearchAdminClass.get_Applications()
atus.OnPreRender(Object sender, EventArgs e)

Everything points to an account, access, or permissions issue. So,
when we go to <<SPS Central Admin>>|Configure Server Farm Account
Settings, everything looks just fine..."Default Content Access
Account" set properly, with the proper password. I even re-entered
the account information to make sure it was right. The account in
question is a member of the Domain admins group on AD.

But, if I go to <<SPS Central Admin>>|Manage the Search Service, I
get the following errors:

Search Service Settings:
Failed to initialize search service settings.
An error occurred attempting to connect to the requested indexing

Servers and Topology:
Proper Server Name, but "Size not available"

Indexes and Propagation:
Proper server name, but "Error collecting statistics"

Sit Hit Frequency Rules:
"An error occurred attempting to connect to the requested indexing

In the application event log, we are getting the following error:

3030 -- the gatherer service cannot be initialized

then, these errors for both the Portal Content and Non Portal
Content indexes:

7039 -- the content index cannot be loaded
7010 -- the index cannot be initialized

Any assistance would be greatly appreciated.



2 Answers Found

Answer #1    Answered By: Diego Paul     Answered On: Oct 03

Is the MSSearch service  up and running? Is the server  you're using
as the index server running?

That's all I can think of for now...

Answer #2    Answered By: Denis Cantrell     Answered On: Oct 03

I think the service  is called Microsoft SharepointPS Search.
Make sure that it up and running and make sure the account  that the
log on account that you are using is the correct one that you want to
run this service.

I also show the RPC service, Sharepoint Portal Administrator, Task
Scheduler, NT LM Security Support Provider as services that the search
depends on. So you may want to check there state too.

Start up type shows as manual for the search  Service.

Also, make sure you do not have three strange files popping up named
Dir, CD, and Program. I believe these are normally dumped in the
Program Files directory. But you may just want to search for them by
For reference on this more rare issue, check this article.

Just some thing to check, hope it helps.

Didn't find what you were looking for? Find more on Search is Broken Or get search suggestion and latest updates.