Logo 
Search:

MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Review link for Infopath 2007 form doesn't open in browser from OOTB

  Asked By: Anila    Date: Feb 08    Category: MOSS    Views: 2358

I created an Infopath 2007 browser enabled form which correctly opens
in a browser by default in my Forms Library. I associated an OOTB
Workflow with this form.

The problem is, whenever the "assigned task" email is sent to the
approver, the link in the email doesn't open the form in the
browser. Instead it tries to open the form in the Infopath client.

Before this issue, I would get the following error whenever following
the workflow link:

"This form has been closed" and "The URL URL_path is an unsupported
relative URL. Use an absolute URL of prefix with '~sitecollection,
for a site-collection-relative URL."

I applied this hotfix which resolved that problem:
http://support.microsoft.com/kb/939592

However, while that particular problem is fixed, the form doesn't
open in a browser from the workflow email. Thoughts?

Share: 

 

2 Answers Found

 
Answer #1    Answered By: Nalin Rao     Answered On: Feb 08

This usually happens because of an errant querystring parameter in the URL.
In the case of the workflow, how is the URL being constructed?

The following article may help you to sort out the details of this problem
depending on your particulars:

msdn.microsoft.com/en-us/library/ms772417.aspx

 
Answer #2    Answered By: Thomas Davis     Answered On: Feb 08

It is missing the "OpenIn=browser" parameter.

The problem is I'm using Out of the Box Workflow, so as far as I
know, I don't have control of how the URL is being constructed.

My alternative is to create a custom workflow where I'd have control
of the URL. I was just hoping I didn't have to.

 




Tagged: