Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Restoring an SPS 2003 portal backup to a different server

  Asked By: Madeline    Date: Jul 08    Category: Sharepoint    Views: 984

I've pulled my hair out over this one, and I don't seem to be
getting anywhere.

I've created a SPS 2003 portal on my machnice, and I need to deploy it
to another server. Think of it as a development to production move. I
used SPSBACKUP.exe to perform a full backup of the _prof, _site and
_serv databases, as well as the team database. It all works well
throught the GUI, and I am also able to restore to my own machine.

Now, when I copy those files to another server (my production
environment) and attempt to restore, it gives me a weird error
regarding a 'search index' or something like that. In short, it
restores all the database, but doesnt fully restore the portal.

Any ideas as to how i can get around this problem...?



7 Answers Found

Answer #1    Answered By: Kabeer Karkare     Answered On: Jul 08

Can you give more details abt the error message ?
Did u try smigrate ? probably check the prod server  service packs and update
the same.

Answer #2    Answered By: Nathaniel Davis     Answered On: Jul 08

By default an SPS Portal can be restored to the original enviroment only (the
same problem will occur when you have WSS). Nver the less Microsoft has got a
tool called "RenameServer" which you will not find on the MSDN pages, this tool
is available throughout the Microsoft Support only. So my personal advice is, to
raise an Microsoft Support Case for the recovery.

I have asked exact this issue the Microsoft Support (when I was in contact with
him based on a general problem with the search service) and talked to them on
about what to do when I want to move my Portal from one to another physical

Answer #3    Answered By: Zoe Cotton     Answered On: Jul 08

Thnaks for that tip...it wasn't mentioned ANYWHERE on the internet!

Do you know where to get old of this "RenameServer" tool from?

Answer #4    Answered By: Alexander Scott     Answered On: Jul 08

The search index is part of the config database.

Answer #5    Answered By: Benito Carey     Answered On: Jul 08

I have now managed to restore my dev portal  to a production
environment without restoring  any search index settings. Can the
search index be reconfigured manually...?

Answer #6    Answered By: Ebony Perkins     Answered On: Jul 08

I have faced that problem in the past. My answer to you is the indexes are on
a new server  and it does not want to restore false pointers to data. So you have
to rebuild your indexes...

Answer #7    Answered By: Anu K     Answered On: Jul 08

I ran into a similar issue.
I use SharePoint out of box back up and restore tool.

Only when you have backed up the portal  with index, you can restore index.
While backing up the portal if you did not back up the index,then you should
not select the 2nd check box(restore of index component).

So while moving from development to production, dont back up the index.Just
back up the portal (you would get 4 files in the back up instead of 5 if you
dont select index in back up) and restore it on the productionserver.

Didn't find what you were looking for? Find more on Restoring an SPS 2003 portal backup to a different server Or get search suggestion and latest updates.