Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Restore works but the site collection list is still empty

  Asked By: Benny    Date: Jul 31    Category: Sharepoint    Views: 4840

I just did a restore of a site which seemed to work. However, the site
collection list is empty. I know that others have had this issue
before but I can't seem to find any solution to the issue.

The content database, the site and everything else seems to be
restored. It just looks like sharepoint has lost a pointer or
something to the data inside the database.

I'd really appreciate any suggestions for remedying this.

Share: 

 

12 Answers Found

 
Answer #1    Answered By: Keenan Whitehead     Answered On: Jul 31

What was the backup from? Which version of SharePoint? I've had
similar issues if I didn't have the correct managed paths set up. Kind
of a long shot for you though.

 
Answer #2    Answered By: Trisha Wheeler     Answered On: Jul 31

The backup was from the command line for Sharepoint (WSS) 3.0. I'll
check out the managed path thing - thanks for the suggestion since
it's not something i've ever had to mess with before.

If anyone has other ideas, please continue to send them.

 
Answer #3    Answered By: Dameon Dejesus     Answered On: Jul 31

Was the backup of a Child site  that you were trying to restore  as the
Top Level Site of a new Site Collection? If so, that doesn't work.
Child sites need to be restored as Child sites.

Also, if you are restoring to the same farm, but a different Site
Collection the restore won't work  because of GUID conflicts with the
original site. To duplicate a site within a farm to a new location you
need to use Export/Import not Backup/Restore.

 
Answer #4    Answered By: Tejaswani Barve     Answered On: Jul 31

No, the restore  was not a child site  - it was a top level web
application that is being restored as a top level web application.

The restore is to a different farm that already has other top level
sharepoint web applications.

Thanks very much for trying to help me sort this out.

 
Answer #5    Answered By: Harshita Padwal     Answered On: Jul 31

What managed path was it Backed up from and what managed path are you
restoring it to. There are two kinds of Managed Paths, explicit and
Wildcard. With a Wildcard managed path the sitecollection  has a name and
with an explicit managed path the name is null. If you try to restore
to the other type of managed path (from where it was backed up) the
presence or lack of a name for the site  collection may cause a problem
also.

 
Answer #6    Answered By: Jennifer Jones     Answered On: Jul 31

The managed path that is in the original farm is blank (null?).
The restore  is occuring to blank(null?) as well. I have never had a
reason to mess with these settings and, to tell you the truth, I'm
not quite sure what they do. So, they are still set to whatever the
WSS defaults are on both the source farm and the target (restore)
farm.

Thanks so much for the suggestions. If you (or anyone else on the
lsit) has any other ideas it would be greatly appreciated.

 
Answer #7    Answered By: Annie Norris     Answered On: Jul 31

I just tried messing with managed paths. I placed an explicit "/"
for the path but, as you suspected that didn't help.

Any other ideas would definitely be appreciated.

 
Answer #8    Answered By: Chadd Hahn     Answered On: Jul 31

You can use Backup/Restore to restore  a second copy to the same farm, you'll
just need to make sure that the restore goes into a different content  Database
than the original. The GUIDs that conflict (list and web GUIDS) are not really
Global in scope, they're really confined to the Content Database. If you try to
restore the Site Collection to the same content database  you'll get an error
that the restore can't continue because no content databases are available. It
won't finish the restore.

 
Answer #9    Answered By: Cheryl Kelley     Answered On: Jul 31

You are correct. Forgot that he was restoring just a Site and not a
full Site Collection.

 
Answer #10    Answered By: Titus Sweet     Answered On: Jul 31

I'm trying to restore  to a different farm, not the original farm.

It's so odd that the entire restore process worked with no error
messages but that the top level site  can't be accessed (site
collection list  is empty). Maybe there's a utility out there that can
crawl through a content  database and create pointers back to the site
somehow??

 
Answer #11    Answered By: Jagdish Joshi     Answered On: Jul 31

If you detach the Content Database and reattach it SharePoint will walk
through the Sites table and add the sites. That's about the closest I
can think of to what you're describing.

 
Answer #12    Answered By: Shara Johnson     Answered On: Jul 31

I tried this but, unfortunately it didn't bring
back the site  collection - the site collection  list is still empty.

So, I guess I'm back to asking the list  for more ideas to try. Any
more suggestions  would be gratefully appreciated.

 
Didn't find what you were looking for? Find more on Restore works but the site collection list is still empty Or get search suggestion and latest updates.




Tagged: