Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

New Requirement for Team Site

  Asked By: Kenya    Date: Apr 14    Category: Sharepoint    Views: 738

I think the client just threw me a nasty curve ball. I am hoping
their is an easy solution to the new requirement -- I have a Team
Site built which consists of links for an Association of Consultants.
These links redirect the user to a sub-site (based upon a modified
Team Site template) which consists of a single page contining a
Content Editor web part that the consultancy can use to create their
own information page. That has all been developed and works in Test
just fine.

Today, however, the client decided that this consultancy page must be
approved by the Site Collection Admin before it is visible on the
site. I know this is possible using thh Publishing Template, but that
is NOT the template we use. Plus, the consultancy sites and default
page are created via a workflow when a new consultant link is added
to a list. And my understanding is that a Publishing site cannot be
saved as a site template.

Is there ANY way ina Team Site to make a page NOT visible until it
has been approved?

Share: 

 

2 Answers Found

 
Answer #1    Answered By: Dan Dickerson     Answered On: Apr 14

Child sites  with publishing  turned on can be saved as a template  manually by
navigating to the _Layouts/savetmpl.aspx page. If you switch the welcome page
for the site  to one in the Pages document library you can also set it up to
require approval before being visible. The one real limitation involved is that
the site built  from this template needs to be in a site collection  with
publishing turned on and that has the same master page, content types, etc. as
the original site collection. Please note that after creating a new site from
this template you will need to go back in and re-enable the Publishing Feature
since that won't come across in the template.

 
Answer #2    Answered By: Phenil Poriya     Answered On: Apr 14

Relating to "Please note that after creating a new site  from this
template you will need to go back in and re-enable the Publishing
Feature since that won't come across in the template."

This has to be done via code. Please see my other post relating to
writing code to turn this on. Having a problem there.

 
Didn't find what you were looking for? Find more on New Requirement for Team Site Or get search suggestion and latest updates.




Tagged: