Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Report server in sharepoint mode - data source credentials

  Asked By: Dominique    Date: Jan 11    Category: Sharepoint    Views: 2813

My Report Server is in SharePoint configuration mode. I need to pass the credentials to access a datasource into a report; I am doing so by passing the credentials on a connection string which is passed as a parameter into the report. I have set the Connection String for my Data Source to be "=Parameters!ConnectionString.Value". I've then set the credentials to 'No Credentials' and I have configured the Unattended Execution Account.

I've got the report to display the connection string that is being passed in, it is as follows:

Server=Machine\OfficeServers;Database=WSS_Content_1fc7264b-e6ec-4ce4-91e9-bddd03aa196c;User ID=User;Password=Password;App=Windows SharePoint Services;Timeout=15

When I access the report from my sharepoint site I get the following message:

"Credentials must be specified before the report can be displayed. Enter credentials in the credentials area and click the Apply button."

I can't understand why, even though I'm passing the credentials in it still prompts for them?

If I set the credentials to 'Use Windows Authentication' it works (obviously only if you are a user with permissions to access the Data Source) If I set the credentials to anything else it always prompts for them (even if I hard code them by selecting 'Use a specific user name and password').

Am I missing something?

Would you normally expect this to work if the report was running on a Report Server not in SharePoint integration mode?

Has anyone ever got a report on a report server in SharePoint integration mode to access a datasource using any credentials other than the currently logged in user?

This is so incredibly frustrating, another seemingly trivial task which SharePoint has inextricably complicated.

As always any help or advice is much appreciated.



1 Answer Found

Answer #1    Answered By: Winston Ayers     Answered On: Jan 11

I've managed to get to the bottom of this - after 3 days...

I did it with help from this post:

It doesn't matter what you configure the datasource  as when you are creating the report  in VS. You need to upload the report to your sharepoint  list and (ensuring you have the 'Report Server Integration' feature activated on your site collection) on the ECB menu for the .rdl file choose manage data  sources - this is where you specify the credentials.

I love how well documented everything to do with SharePoint is.

Didn't find what you were looking for? Find more on Report server in sharepoint mode - data source credentials Or get search suggestion and latest updates.

Related Topics: