Logo 
Search:

MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Report Server has encountered a SharePoint Error

  Asked By: Angelique    Date: Aug 30    Category: MOSS    Views: 3003

I've got a mid-sized SharePoint farm set up as follows:

FE01 - SharePoint Web Front End w/ Query (MOSS, Project Server)
FE02 - Sharepoint Web Front End w/ Query (MOSS, Project Server)
App01 - SharePoint Web Front End, Index, Excel Services, SQL Reporting Services 2008 SharePoint Integrated Mode (MOSS, Project Server)
App02 - Project Server Application Service (MOSS, Project Server)
SQL01 - SQL 2008 DB Engine, Analysis Services

All servers that have MOSS and Project Server are running SP2 and April CU for WSS/MOSS. All SQL instances are running SP1 with CU3.

All servers are in the same domain, and all SQL services are running as domain user accounts.

I've installed and configured MOSS and Project Server, and they both work as expected. I then installed SQL Reporting Services (SharePoint integrated mode) and configured that to work with SharePoint. I installed the Reporting Services 2008 Add-In on all of the SharePoint servers except App02 (in order for the cube to build there can't be SQL 2008 components on that machine according to technet.microsoft.com/en-us/library/dd285466.aspx). I configured SharePoint under Central Admin to grant DB access, and manage integration settings.

Now everything is set up, and when I go to run a report or edit a database connection I get the error listed below:


System.Web.Services.Protocols.SoapException: Report Server has encountered a SharePoint error. ---> Microsoft.ReportingServices.Diagnostics.Utilities.SharePointException: Report Server has encountered a SharePoint error.
at Microsoft.ReportingServices.WebServer.ReportingService2005Impl.GetItemDataSources(String Item, DataSource[]& DataSources)
at Microsoft.ReportingServices.WebServer.ReportingService2006.GetItemDataSources(String Item, DataSource[]& DataSources)

There isn't anything in the event logs, and the SharePoint ULS logs show the following string of information:

09/02/2009 08:11:23.81 ReportingServicesService.exe (0x07A4) 0x0F68 Windows SharePoint Services General 72l8 High VcomCache: Failed to QI for interface IID = {BDEADF12-C265-11D0-BCED-00A0C90AB50F}, PUNK = 0x03adfe18, HR=0x80131014
09/02/2009 08:11:23.87 ReportingServicesService.exe (0x07A4) 0x0F68 Windows SharePoint Services General 72l9 Medium VcomCache: The QI failed, retrying... HR=0x80131014

I've been trying to solve this issue for about four days straight now and am starting to lose my sanity... Any help would be appeciated, and any/all suggestions will be tried.

Share: 

 

1 Answer Found

 
Answer #1    Answered By: Ravindra Salvi     Answered On: Aug 30

It ended up being an issue with the reports themselves. They couldn't reach the data sources, but for some reason also wouldn't let you edit the reports or data sources (or even go to Manage Data Sources) thru SharePoint. Ended up having to copy them off, edit them with notepad, and then upload them back to the site.

 
Didn't find what you were looking for? Find more on Report Server has encountered a SharePoint Error Or get search suggestion and latest updates.

Related Topics:



Tagged:          

 

Related Post